Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-242

Inconsistent state of the Entry Editor after using "New Value" (or "New Attribute...") and pressing "Escape".

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.0.1
    • Fix Version/s: 1.1.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None

      Description

      Inconsistent state of the Entry Editor after using "New Value" (or "New Attribute...") and pressing "Escape".

      Steps to reproduce:

      • Display an Entry in the Entry Editor.
      • Click on the "New Value" button
      • Press "Escape"
        => The Entry Editor is left with an empty value for the attribute and does not reflect the actual state on the server.

      I think the newly added value should be removed.

      The same problem occurs with the "New Attribute..." button.

        Activity

        Pierre-Arnaud Marcelot added a comment -

        Closing this issue.

        Pierre-Arnaud Marcelot added a comment -

        Ok, I see, this is a valid test case then.

        It's the only way to edit a newly created attribute with a 'non-default' editor.

        Thanks for the explanation.

        Stefan Seelmann added a comment -

        This is the intended behaviour

        I remember one use case: When adding an attribute or value, the default ValueEditor is opened. If the user wants to edit it using another value editor, s/he must escape editing and select another value editor from the context menu. When we remove the empty value after escape this won't be possible.

        Do you think, this is a valid use case?

        BTW: The empty value is marked (bold and red colored by default) to signal that this value isn't written to the directory.


          People

          • Assignee:
            Unassigned
            Reporter:
            Pierre-Arnaud Marcelot
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development