Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-180

Connection wizard and properties tabs are out of order

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0
    • Fix Version/s: 1.0.1
    • Component/s: studio-connection
    • Labels:
      None
    • Environment:
      Fedora Core 6 Linux, JDK

      Description

      When I installed Studio on my Linux system, it appears as if the connection wizard and properties editor tabs are out of order. When you click on "New Connection..." the first thing you see is Browser Options and all buttons are disabled. If you unselect "Get Base DN from root DSE" you can go then click the "next" button and configure the network parameters.

      If you edit properties of an existing connection the editor tabs are in the same order.

      I will attach screenshots to demonstrate. I also tried the same thing on Windows which appears to have normal behavior.

      1. Screenshot-Properties.png
        31 kB
        Chris Custine
      2. Screenshot-New LDAP Connection 3.png
        31 kB
        Chris Custine
      3. Screenshot-New LDAP Connection 2.png
        30 kB
        Chris Custine
      4. New LDAP Connection1.png
        30 kB
        Chris Custine

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        9h 19m 1 Stefan Seelmann 02/Sep/07 13:09
        Resolved Resolved Closed Closed
        285d 41m 1 Pierre-Arnaud Marcelot 13/Jun/08 13:50
        Pierre-Arnaud Marcelot made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Hide
        Pierre-Arnaud Marcelot added a comment -

        Version 1.0.1 has been released.
        Closing this issue.

        Show
        Pierre-Arnaud Marcelot added a comment - Version 1.0.1 has been released. Closing this issue.
        Stefan Seelmann made changes -
        Fix Version/s 1.0.0 [ 12312288 ]
        Fix Version/s 1.0.1 [ 12312702 ]
        Hide
        Stefan Seelmann added a comment -

        Rolled back the change from 1.0.0 here: http://svn.apache.org/viewvc?rev=572124&view=rev

        Show
        Stefan Seelmann added a comment - Rolled back the change from 1.0.0 here: http://svn.apache.org/viewvc?rev=572124&view=rev
        Stefan Seelmann made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Hide
        Stefan Seelmann added a comment -

        Fixed by adding dependency between the connection pages.

        Fixed in trunk: http://svn.apache.org/viewvc?rev=571961&view=rev
        Fixed in 1.0.0: http://svn.apache.org/viewvc?rev=571963&view=rev

        Show
        Stefan Seelmann added a comment - Fixed by adding dependency between the connection pages. Fixed in trunk: http://svn.apache.org/viewvc?rev=571961&view=rev Fixed in 1.0.0: http://svn.apache.org/viewvc?rev=571963&view=rev
        Stefan Seelmann made changes -
        Fix Version/s 1.0.0 [ 12312288 ]
        Assignee Stefan Seelmann [ seelmann ]
        Hide
        Stefan Seelmann added a comment -

        Thanks Chris, for this catch.

        With the new connection plugin I splitted the connection pages. The two pages "Network paramter" and "Authentication" were moved to the connection plugin, however the "Browser options" page is still located in the browser plugin. At runtime they are loaded using the Eclipse extension mechanism.

        I haven't added any order to these pages, because the browser plugin depens on the connection plugin, so the connection plugin is loaded first. I didn't run into that problem and I thought that the connection pages are loaded in the same order as the plugins.

        Show
        Stefan Seelmann added a comment - Thanks Chris, for this catch. With the new connection plugin I splitted the connection pages. The two pages "Network paramter" and "Authentication" were moved to the connection plugin, however the "Browser options" page is still located in the browser plugin. At runtime they are loaded using the Eclipse extension mechanism. I haven't added any order to these pages, because the browser plugin depens on the connection plugin, so the connection plugin is loaded first. I didn't run into that problem and I thought that the connection pages are loaded in the same order as the plugins.
        Chris Custine made changes -
        Attachment Screenshot-Properties.png [ 12364957 ]
        Chris Custine made changes -
        Attachment Screenshot-New LDAP Connection 3.png [ 12364956 ]
        Chris Custine made changes -
        Attachment Screenshot-New LDAP Connection 2.png [ 12364955 ]
        Chris Custine made changes -
        Field Original Value New Value
        Attachment New LDAP Connection1.png [ 12364954 ]
        Chris Custine created issue -

          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Chris Custine
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development