Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-M9 (2.0.0.v20150606-M9)
    • Fix Version/s: 2.0.0-M11, 2.0.0-M12
    • Component/s: None
    • Labels:
      None
    • Environment:
      Ubuntu 15.10, Oracle JRE 9

      Description

      ADS fails to startup and displays an error message wich says:

      An error has occurred. See the log file
      /home/user/.ApacheDirectoryStudio/.metadata/.log.

      $ cat ~/.ApacheDirectoryStudio/.metadata/.log
      !SESSION 2015-11-05 09:50:31.899 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.9.0-ea
      java.vendor=Oracle Corporation
      BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
      Framework arguments: /studio-rcp/resources/icons/linux/studio.xpm
      Command-line arguments: -os linux -ws gtk -arch x86_64 /studio-rcp/resources/icons/linux/studio.xpm

      !ENTRY org.eclipse.osgi 4 0 2015-11-05 09:50:36.825
      !MESSAGE Application error
      !STACK 1
      java.lang.NoClassDefFoundError: org/w3c/dom/stylesheets/StyleSheet
      at org.eclipse.e4.ui.css.swt.internal.theme.ThemeEngineManager.getCSSSWTEngine(ThemeEngineManager.java:41)
      at org.eclipse.e4.ui.css.swt.internal.theme.ThemeEngineManager.getEngineForDisplay(ThemeEngineManager.java:30)
      at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.createThemeEngine(PartRenderingEngine.java:1428)
      at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.initializeStyling(PartRenderingEngine.java:1281)
      at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1036)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
      at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1032)
      at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:148)
      at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:636)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:579)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
      at org.apache.directory.studio.Application.start(Application.java:51)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:519)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
      at org.eclipse.equinox.launcher.Main.main(Main.java:1438)
      Caused by: java.lang.ClassNotFoundException: org.w3c.dom.stylesheets.StyleSheet cannot be found by org.eclipse.e4.ui.css.core_0.10.100.v20140424-2042
      at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:432)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:345)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:337)
      at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:160)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
      ... 26 more

        Activity

        seelmann Stefan Seelmann added a comment -

        Studio is now based on Eclipse Mars and works with Java 9.

        seelmann Stefan Seelmann added a comment -

        Studio 2.0.0-M9 is based on Eclipse Luna.

        There are many bug reports that Eclipse Luna doesn't work with Java 9:

        It seems to be fixed in Eclipse Mars, so at some point we need to upgrade.


          People

          • Assignee:
            seelmann Stefan Seelmann
            Reporter:
            jonykalavera Jony Kalavera
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development