Uploaded image for project: 'Directory Studio'
  1. Directory Studio
  2. DIRSTUDIO-1065

Have a better error message when the java version is wrong

    Details

      Description

      As pointed out in the thread in the dev.ml http://directory.markmail.org/message/2bwjbeu57gjdlau5 the error message is not very informative.

      A better message will improve the user experience.

        Activity

        Hide
        seelmann Stefan Seelmann added a comment -

        I'll try to find out if that is possible. However the error message is produced by the underlying Eclipse RCP framework, so I doubt that we can easily change that.

        Show
        seelmann Stefan Seelmann added a comment - I'll try to find out if that is possible. However the error message is produced by the underlying Eclipse RCP framework, so I doubt that we can easily change that.
        Hide
        seelmann Stefan Seelmann added a comment -

        Jeff Maury wrote on the ML:

        Looked at the Windows 64bit and it seems to me the ApacheDirectoryStudio.ini is missing the -Dosgi.requiredJavaVersion=1.7 directive to make sure the JVM selection process will pick up the proper JVM

        Show
        seelmann Stefan Seelmann added a comment - Jeff Maury wrote on the ML: Looked at the Windows 64bit and it seems to me the ApacheDirectoryStudio.ini is missing the -Dosgi.requiredJavaVersion=1.7 directive to make sure the JVM selection process will pick up the proper JVM
        Hide
        seelmann Stefan Seelmann added a comment -

        Fixed here: http://svn.apache.org/viewvc?rev=1718189&view=rev

        Now -Dosgi.requiredJavaVersion=1.7 is added to ApacheDirectoryStudio.ini. When starting Studio with Java 1.6 on Linux (I hope same on OSX and Windows) I get the following error message:

        Incompatible JVM
        Version 1.6.0_45 of the JVM is not suitable for this product. Version: 1.7 or greater is required.

        Show
        seelmann Stefan Seelmann added a comment - Fixed here: http://svn.apache.org/viewvc?rev=1718189&view=rev Now -Dosgi.requiredJavaVersion=1.7 is added to ApacheDirectoryStudio.ini . When starting Studio with Java 1.6 on Linux (I hope same on OSX and Windows) I get the following error message: Incompatible JVM Version 1.6.0_45 of the JVM is not suitable for this product. Version: 1.7 or greater is required.

          People

          • Assignee:
            seelmann Stefan Seelmann
            Reporter:
            pfm.smits Pierre Smits
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development