Uploaded image for project: 'Directory Studio'
  1. Directory Studio
  2. DIRSTUDIO-1014

Cannot remove the 'finished operations' in the progress pane

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-M8 (2.0.0.v20130628)
    • Component/s: None
    • Labels:
      None

      Description

      The 'progress' pane list the ongoing operations as the finished operations (should be 'completed'). There is a drop down menu that allows you to remove the completed operations, but it's not doing anything.

        Activity

        seelmann Stefan Seelmann added a comment -

        I was able to reproduce this: When opening a connection fails because the server is not running the "Open Connection" job remains in the "Progess" view and it is not removeable.

        seelmann Stefan Seelmann added a comment -

        This is hopefully fixed. I think the pb was that monitor.subTask(message) was called from another thread than the job's thread.

        http://svn.apache.org/r1682562


          People

          • Assignee:
            seelmann Stefan Seelmann
            Reporter:
            elecharny Emmanuel Lecharny
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development