Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.0.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None

      Description

      When the JVM brutally exit (OOM for instance), the browser connection configuration is lost. I have to recreate them after having restarted LdapStudio...

        Activity

        Stefan Seelmann added a comment -

        I assume that could happen if the crash occurs while writing the configuration to the configuration file. That could result in a corrupt configuration file. I suggest to backup the old configuration file just before writing the new one. Then the old configuration could be recovered after such a crash.

        Emmanuel Lecharny added a comment -

        No, unless writing the configuration occurs just when the application is crashing

        I guess that the problem is that the configuration is not written immediatly after having created the new connection, or that when restarting LS, it does not read the current modification for some reason.

        Usually, I get this error after having created a new config, opened the browser, browsed for some entry, and decided to kill LS brutally. The config seems to be ignored when restarting LS.

        Stefan Seelmann added a comment -

        I wasn't able to reproduce that issue.

        What OS and JVM are you using?
        Does this also occur on other OS or when using other JVMs?
        If the error occurs, are all your connections lost or just the one you created?

        Stefan Seelmann added a comment -

        I added code to write configuration into a temporary file first, then rename it to the real configuration file. This should reduce the probability of loosing configuration. http://svn.apache.org/viewvc?view=rev&rev=548133

        Emmanuel, could you please test it?


          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Emmanuel Lecharny
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development