Uploaded image for project: 'Directory ApacheDS'
  1. Directory ApacheDS
  2. DIRSERVER-2128

Uplift dependency on commons-io from 2.4 to 2.5

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-M21
    • Fix Version/s: 2.0.0-M22
    • Component/s: core
    • Labels:
      None
    • Environment:
      Windows / Linux

      Description

      HI,
      This request is here because of this commons-io issue:
      https://issues.apache.org/jira/browse/IO-487

      Emmanuel mentioned that the use of commons-io is limited to the FileUtils class and that a new implementation that doesn't rely on the library may be a better solution.

      Thank you.

        Activity

        Hide
        elecharny Emmanuel Lecharny added a comment -

        The dependency on commons-io has been removed completely from teh LDAP API and ApacheDS.

        Show
        elecharny Emmanuel Lecharny added a comment - The dependency on commons-io has been removed completely from teh LDAP API and ApacheDS.
        Hide
        caccorsi Carlo Accorsi added a comment -

        Wow!! Thanks for the amazingly quick response!!

        Show
        caccorsi Carlo Accorsi added a comment - Wow!! Thanks for the amazingly quick response!!
        Hide
        elecharny Emmanuel Lecharny added a comment -

        It was quick because the removal was done last week

        Show
        elecharny Emmanuel Lecharny added a comment - It was quick because the removal was done last week

          People

          • Assignee:
            Unassigned
            Reporter:
            caccorsi Carlo Accorsi
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development