Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-M17
    • Fix Version/s: 2.0.0-M18
    • Component/s: None
    • Labels:
    • Environment:
      Does not matter, component does not exist as this ticket applies to the artifact apacheds-all

      Description

      The artifacte apacheds-all artifact includes classes cpoied there from other libraries (such as the Bouncycastle classes for parsing ASN1).

      However in this case the licence of the original must be correctly applied. In the case of the classes from Bouncycastle the solution is as follows:

      • Use the ASF 2.0 licence for the apacheds-all but add a hint that the code in the package org\bouncycastle\ (whichever contains the classes) is taken from bouncycastle and that for this package the additional statement ... (check the Bouncycastle licence to get the statement, Bouncycastle licence is derived from MIT Licence) is part of the licence. Furthermore state that this additional part must be preserved in case of any further sublicencing of this code in the org.bouncycastle package additionally to the requirements defined by the ASF licence.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              zyrano Sebastian Oerding
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1h
                1h
                Remaining:
                Remaining Estimate - 1h
                1h
                Logged:
                Time Spent - Not Specified
                Not Specified