Directory ApacheDS
  1. Directory ApacheDS
  2. DIRSERVER-1846

Configuring SSL/Start TLS keystore does not accept backward slash (\) in path

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-M12
    • Fix Version/s: 2.0.0-M13
    • Component/s: schema
    • Labels:
    • Environment:
      Windows 7,
      32 - Bit

      Description

      Usability failure
      Creating a LDAPS configuration in Apache Directory studio does not accept backward slash () in the path (winwdows path). After a much struggling and with help of forum support it is pointed that Studio does not accept ().

      This is usability issue. Normally, in windows, path is recognized by the backward slash (). This has to to be escaped implicitly.

        Issue Links

          Activity

          ashwin kumar created issue -
          Emmanuel Lecharny added a comment -

          I suspect that the problem is with back slash, not forward slash...

          ashwin kumar added a comment -

          Yes. My bad.

          Emmanuel Lecharny made changes -
          Field Original Value New Value
          Summary Configuring SSL/Start TLS keystore does not accept forward slash (/) in path Configuring SSL/Start TLS keystore does not accept backward slash (\) in path
          Emmanuel Lecharny made changes -
          Description *Usability failure*
          Creating a LDAPS configuration in Apache Directory studio does not accept forward slash (/) in the path. After a much struggling and with help of forum support it is pointed that Studio does not accept (/).

          This is usability issue. Normally, in windows, path is recognized by the forward slash (/). This has to to be escaped implicitly.

          *Usability failure*
          Creating a LDAPS configuration in Apache Directory studio does not accept backward slash (\) in the path (winwdows path). After a much struggling and with help of forum support it is pointed that Studio does not accept (\).

          This is usability issue. Normally, in windows, path is recognized by the backward slash (\). This has to to be escaped implicitly.

          Emmanuel Lecharny added a comment -

          Fixed forwad to backward

          Pierre-Arnaud Marcelot made changes -
          Project Directory Studio [ 12310590 ] Directory ApacheDS [ 12310260 ]
          Key DIRSTUDIO-908 DIRSERVER-1846
          Component/s schema [ 12311628 ]
          Component/s studio-ldifeditor [ 12311948 ]
          Pierre-Arnaud Marcelot added a comment -

          I just moved this issue to the ApacheDS project.

          This is not typically an Apache Directory Studio issue.
          What occurs is that the value for the SSL/Start TLS keystore file is stored in the 'ads-keystoreFile' attribute type, which uses a 'Printable String' syntax.

          The problem is that the 'Printable String' syntax does not allow backslash value ('\').

          We should change the syntax to something which allows it ('IA5 String' is probably the right solution).

          Pierre-Arnaud Marcelot made changes -
          Affects Version/s 2.0.0-M12 [ 12324098 ]
          Fix Version/s 2.0.0-RC1 [ 12313387 ]
          Pierre-Arnaud Marcelot made changes -
          Link This issue duplicates DIRSERVER-1816 [ DIRSERVER-1816 ]
          Pierre-Arnaud Marcelot added a comment -

          Added a link to a previous issue describing the same problem.

          Emmanuel Lecharny added a comment -
          Emmanuel Lecharny made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Emmanuel Lecharny made changes -
          Fix Version/s 2.0.0-M13 [ 12324631 ]
          Fix Version/s 2.0.0-RC1 [ 12313387 ]
          Emmanuel Lecharny made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          8d 5h 47m 1 Emmanuel Lecharny 22/May/13 15:06
          Resolved Resolved Closed Closed
          28d 20h 6m 1 Emmanuel Lecharny 20/Jun/13 11:12

            People

            • Assignee:
              Unassigned
              Reporter:
              ashwin kumar
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development