Directory ApacheDS
  1. Directory ApacheDS
  2. DIRSERVER-1340

Search the schema partition for (objectClass=metaTop) returns no results

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.5.4
    • Fix Version/s: 1.5.6
    • Component/s: schema
    • Labels:
      None

      Description

      Search the schema partition for (objectClass=metaTop) returns no results.

      Search for (objectClass=top) or (objectClass=metaAttributeType) works fine.

        Activity

        Stefan Seelmann created issue -
        Stefan Seelmann made changes -
        Field Original Value New Value
        Environment Search the schema partition for (objectClass=metaTop) returns no results
        Description Search the schema partition for (objectClass=metaTop) returns no results.

        Search for (objectClass=top) or (objectClass=metaAttributeType) works fine.

        Stefan Seelmann added a comment -

        Attached test to demonstrate the bug.

        Stefan Seelmann made changes -
        Attachment DIRSERVER-1340-test.patch [ 12403736 ]
        Emmanuel Lecharny added a comment -

        Let's try to fix it for 1.5.5

        Emmanuel Lecharny made changes -
        Fix Version/s 1.5.5 [ 12313148 ]
        Emmanuel Lecharny added a comment -

        Postponed to 2.0.0-RC1

        Emmanuel Lecharny made changes -
        Fix Version/s 2.0.0-RC1 [ 12313387 ]
        Fix Version/s 1.5.5 [ 12313148 ]
        Kiran Ayyagari added a comment - - edited

        Tested against the trunk, looks like this issue has been resolved during the schema subsystem rewrite. Committed the test case here http://svn.apache.org/viewvc?rev=917192&view=rev

        Kiran Ayyagari made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Kiran Ayyagari [ akiran ]
        Fix Version/s 1.5.6 [ 12314538 ]
        Fix Version/s 2.0.0-RC1 [ 12313387 ]
        Resolution Cannot Reproduce [ 5 ]
        Stefan Seelmann made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        338d 19h 1m 1 Kiran Ayyagari 28/Feb/10 15:49
        Resolved Resolved Closed Closed
        87d 2h 17m 1 Stefan Seelmann 26/May/10 18:06

          People

          • Assignee:
            Kiran Ayyagari
            Reporter:
            Stefan Seelmann
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development