Uploaded image for project: 'MINA'
  1. MINA
  2. DIRMINA-972

NPE during handshake on Android using SSLFilter

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0.8
    • Component/s: Filter
    • Labels:
      None
    1. SSLProviderDiff.html
      8 kB
      Christopher Deschenes

      Activity

      chrisd Christopher Deschenes added a comment -

      We suspect that the root cause of the trouble is a race condition triggered by the amount of extra time it takes for the Android SSL Engine to secure the connection. I suspect that this part of the MINA code doesn't cause problems for PC users since the SSL Engine in regular Java (not Dalvik) is much faster than Android or behaves differently under the hood.

      elecharny Emmanuel Lecharny added a comment -

      Patch applied (sorry for the incredibly long delay...)

      commit af34f5087926b6e44c62033567123244cabed1f8


        People

        • Assignee:
          Unassigned
          Reporter:
          chrisd Christopher Deschenes
        • Votes:
          1 Vote for this issue
          Watchers:
          3 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development