Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.0.4
    • Fix Version/s: 3.0.0-M1
    • Component/s: None
    • Labels:
      None

      Description

      The APR code should be unit tested.

        Issue Links

          Activity

          Hide
          Julien Vermillard added a comment -

          the main problem is to automagicly install the tomcat native libs with maven, any idea ?

          Show
          Julien Vermillard added a comment - the main problem is to automagicly install the tomcat native libs with maven, any idea ?
          Hide
          Alan Cabrera added a comment -

          Hmmm, good point. How does Tomcat test?

          I was thinking of using profiles, or something like that.

          Show
          Alan Cabrera added a comment - Hmmm, good point. How does Tomcat test? I was thinking of using profiles, or something like that.
          Hide
          Julien Vermillard added a comment -

          I think if we want to do that, we need to fix tomcat native first :
          it's not maven based and the test suite is supposed to be run on an environment with all the native libs deployed.
          http://svn.apache.org/repos/asf/tomcat/native/trunk/

          Show
          Julien Vermillard added a comment - I think if we want to do that, we need to fix tomcat native first : it's not maven based and the test suite is supposed to be run on an environment with all the native libs deployed. http://svn.apache.org/repos/asf/tomcat/native/trunk/
          Hide
          Ashish Paliwal added a comment -

          Which release do we fit this into? Seems like we can move this to 3.0

          Show
          Ashish Paliwal added a comment - Which release do we fit this into? Seems like we can move this to 3.0
          Hide
          Emmanuel Lecharny added a comment -

          anytime after 2.0 is ok. We can even inject those tests in a 2.0.1 if needed

          Show
          Emmanuel Lecharny added a comment - anytime after 2.0 is ok. We can even inject those tests in a 2.0.1 if needed
          Hide
          Emmanuel Lecharny added a comment -

          Affected it to 3.0.0

          Show
          Emmanuel Lecharny added a comment - Affected it to 3.0.0
          Hide
          Julien Vermillard added a comment -

          since for now we don't want APR in MINA 3 it's not needed anymore

          Show
          Julien Vermillard added a comment - since for now we don't want APR in MINA 3 it's not needed anymore

            People

            • Assignee:
              Unassigned
              Reporter:
              Alan Cabrera
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development