Uploaded image for project: 'Directory Client API'
  1. Directory Client API
  2. DIRAPI-58

Method org.apache.directory.ldap.client.api.LdapConnection.loadSchema() should be renamed as loadDefaultSchema() to avoid confusion

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0-M1, 1.0.0-M2, 1.0.0-M3, 1.0.0-M4, 1.0.0-M5, 1.0.0-M6, 1.0.0-M7, 1.0.0-M8
    • Fix Version/s: 1.0.0-M11
    • Labels:
      None

      Description

      At first, I thought the method org.apache.directory.ldap.client.api.LdapConnection.loadSchema() could be used to load the schema of the remote server via the connection.

      Instead, it turned out it is loading the default (ApacheDS) schema bundled with API.

      Maybe it would be better to rename this method as loadDefaultSchema() to avoid confusion.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                pamarcelot Pierre-Arnaud Marcelot
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: