Details
-
Improvement
-
Status: Open
-
Major
-
Resolution: Unresolved
-
None
-
None
Description
Inconsistent method names:
- Attribute: getString() and getBytes()
- Value: getValue() and getBytes()
- Proposal: Rename Value.getValue() to Value.getString()
Inconsistent and wrong documented error handling:
- Attribute: getString() and getBytes() check for isHumanReadable and throw LdapInvalidAttributeValueException
- Value: getValue()/getString() tries to UTF-8 encode bytes if not human readable, which doesn't work always, and javadoc says "returns null"
- Value: getBytes() doesn't check if is human readable
- Proposal: Make Value behave like Attribute, i.e. throw LdapInvalidAttributeValueException
Opinions?