Uploaded image for project: 'Directory Client API'
  1. Directory Client API
  2. DIRAPI-252

Compiling warnings while api-all is in dependencies

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.0.0-M31
    • Fix Version/s: 1.0.0-M32
    • Labels:
      None

      Description

      We are using client-api-all as a dependency in our build (ant+oracle java7)
      We get following compiler warnings as a result

      [javac] /home/solomax/work/openmeetings/branches/3.0.x/build/lib/om/api-all-jar-1.0.0-M31.jar(org/apache/directory/api/ldap/model/name/Dn.class): warning: Cannot find annotation method 'value()' in type 'SuppressWarnings': class file for edu.umd.cs.findbugs.annotations.SuppressWarnings not found
      [javac] /home/solomax/work/openmeetings/branches/3.0.x/build/lib/om/api-all-jar-1.0.0-M31.jar(org/apache/directory/api/ldap/model/name/Dn.class): warning: Cannot find annotation method 'justification()' in type 'SuppressWarnings'
      [javac] Note: Starting OpenJPA Annotation Processor for Metamodel Generation
      [javac] warning: Supported source version 'RELEASE_6' from annotation processor 'org.apache.openjpa.persistence.meta.AnnotationProcessor6' less than -source '1.7'
      [javac] /home/solomax/work/openmeetings/branches/3.0.x/build/lib/om/api-all-jar-1.0.0-M31.jar(org/apache/directory/api/ldap/model/name/Dn.class): warning: Cannot find annotation method 'value()' in type 'SuppressWarnings': class file for edu.umd.cs.findbugs.annotations.SuppressWarnings not found
      [javac] /home/solomax/work/openmeetings/branches/3.0.x/build/lib/om/api-all-jar-1.0.0-M31.jar(org/apache/directory/api/ldap/model/name/Dn.class): warning: Cannot find annotation method 'justification()' in type 'SuppressWarnings'
      [javac] /home/solomax/work/openmeetings/branches/3.0.x/build/lib/om/api-all-jar-1.0.0-M31.jar(org/apache/directory/api/ldap/model/name/Dn.class): warning: Cannot find annotation method 'value()' in type 'SuppressWarnings': class file for edu.umd.cs.findbugs.annotations.SuppressWarnings not found
      [javac] /home/solomax/work/openmeetings/branches/3.0.x/build/lib/om/api-all-jar-1.0.0-M31.jar(org/apache/directory/api/ldap/model/name/Dn.class): warning: Cannot find annotation method 'justification()' in type 'SuppressWarnings'
      [javac] /home/solomax/work/openmeetings/branches/3.0.x/build/lib/om/api-all-jar-1.0.0-M31.jar(org/apache/directory/api/ldap/model/name/Dn.class): warning: Cannot find annotation method 'value()' in type 'SuppressWarnings': class file for edu.umd.cs.findbugs.annotations.SuppressWarnings not found
      [javac] /home/solomax/work/openmeetings/branches/3.0.x/build/lib/om/api-all-jar-1.0.0-M31.jar(org/apache/directory/api/ldap/model/name/Dn.class): warning: Cannot find annotation method 'justification()' in type 'SuppressWarnings'

      I believe it will be good idea to eliminate whose
      Thanks

        Activity

        elecharny Emmanuel Lecharny added a comment -

        Should be fixed by http://svn.apache.org/viewvc?rev=1706658&view=rev

        Thanks for the report !

        solomax Maxim Solodovnik added a comment -

        I believe this is caused by the fact edu.umd.cs.findbugs.annotations.SuppressWarnings is used instead of java.lang.SuppressWarnings


          People

          • Assignee:
            Unassigned
            Reporter:
            solomax Maxim Solodovnik
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development