Uploaded image for project: 'Directory Client API'
  1. Directory Client API
  2. DIRAPI-126

Timeout Exception on bind while pwdExpireWarning period

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0-M16
    • Fix Version/s: 1.0.0-M21
    • Labels:
      None
    • Environment:
      CentOS

      Description

      When I reach the pwdExpireWarning period I get can't get the expire warning from ppolicy instead I get a timeout. When the password is exipred, it works again.

      sample config:
      ads-pwdId: default
      ads-pwdSafeModify: FALSE
      ads-pwdMaxAge: 1800
      ads-pwdFailureCountInterval: 30
      ads-pwdAttribute: userPassword
      ads-pwdMaxFailure: 5
      ads-pwdLockout: TRUE
      ads-pwdMustChange: TRUE
      ads-pwdLockoutDuration: 0
      ads-pwdMinLength: 5
      ads-pwdInHistory: 5
      ads-pwdExpireWarning: 900
      ads-pwdMinAge: 0
      ads-pwdAllowUserChange: TRUE
      ads-pwdGraceAuthNLimit: 5
      ads-pwdCheckQuality: 1
      ads-pwdMaxLength: 0
      ads-pwdGraceExpire: 0
      ads-pwdMinDelay: 0
      ads-pwdMaxDelay: 0
      ads-pwdMaxIdle: 0
      ads-enabled: TRUE

      17:32:59,759 Kommentar persistenzldap.StandaloneLdapApiService:261 - Registered pre-bundled control factory: 1.3.6.1.4.1.42.2.27.8.5.1
      17:32:59,768 Kommentar persistenzldap.StandaloneLdapApiService:261 - Registered pre-bundled control factory: 1.3.6.1.4.1.4203.1.9.1.3
      17:32:59,769 Kommentar persistenzldap.StandaloneLdapApiService:261 - Registered pre-bundled control factory: 1.3.6.1.4.1.4203.1.9.1.4
      17:32:59,771 Kommentar persistenzldap.StandaloneLdapApiService:261 - Registered pre-bundled control factory: 1.3.6.1.4.1.4203.1.9.1.1
      17:32:59,772 Kommentar persistenzldap.StandaloneLdapApiService:261 - Registered pre-bundled control factory: 1.3.6.1.4.1.4203.1.9.1.2
      17:32:59,969 Kommentar persistenzldap.LDAPOperationsImpl:594 - Ereignisnummer: [06016] - LDAP Nutzer Authentifizierung für M.MOOG
      17:33:30,207 Fehler persistenzldap.LdapNetworkConnection:1094 - Bind failed : timeout occurred
      17:33:30,211 Fehler persistenzldap.LdapNetworkConnection:1122 - The response queue has been emptied, no response was found.
      org.apache.directory.api.ldap.model.exception.LdapException: TimeOut occurred
      at org.apache.directory.ldap.client.api.LdapNetworkConnection.bind(LdapNetworkConnection.java:1095)
      at de.deutschepost.ubbrief.postident.ldap.impl.LDAPOperationsImpl.nutzerAuthentifizieren(LDAPOperationsImpl.java:603)
      at de.deutschepost.ubbrief.postident.ldap.LDAPTest.testNutzerAuthentifizieren(LDAPTest.java:304)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:45)
      at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
      at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:42)
      at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
      at org.junit.runners.ParentRunner.runLeaf(ParentRunner.java:263)
      at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:68)
      at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:47)
      at org.junit.runners.ParentRunner$3.run(ParentRunner.java:231)
      at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:60)
      at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:229)
      at org.junit.runners.ParentRunner.access$000(ParentRunner.java:50)
      at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:222)
      at org.junit.runners.ParentRunner.run(ParentRunner.java:300)
      at org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:50)
      at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
      at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:467)
      at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:683)
      at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:390)
      at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:197)
      17:33:30,216 Fehler persistenzldap.PersistenzldapException:64 - Ereignisnummer: [06100] - Beim Zugriff auf LDAP ist ein Fehler aufgetreten!
      org.apache.directory.api.ldap.model.exception.LdapException: The response queue has been emptied, no response was found.
      at org.apache.directory.ldap.client.api.LdapNetworkConnection.bind(LdapNetworkConnection.java:1123)
      at de.deutschepost.ubbrief.postident.ldap.impl.LDAPOperationsImpl.nutzerAuthentifizieren(LDAPOperationsImpl.java:603)
      at de.deutschepost.ubbrief.postident.ldap.LDAPTest.testNutzerAuthentifizieren(LDAPTest.java:304)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:45)
      at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
      at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:42)
      at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
      at org.junit.runners.ParentRunner.runLeaf(ParentRunner.java:263)
      at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:68)
      at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:47)
      at org.junit.runners.ParentRunner$3.run(ParentRunner.java:231)
      at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:60)
      at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:229)
      at org.junit.runners.ParentRunner.access$000(ParentRunner.java:50)
      at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:222)
      at org.junit.runners.ParentRunner.run(ParentRunner.java:300)
      at org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:50)
      at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
      at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:467)
      at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:683)
      at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:390)
      at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:197)
      Caused by: org.apache.directory.api.ldap.model.exception.LdapException: TimeOut occurred
      at org.apache.directory.ldap.client.api.LdapNetworkConnection.bind(LdapNetworkConnection.java:1095)
      ... 25 more

        Activity

        akiran Kiran Ayyagari added a comment -

        This is not reproducible against the current trunk version M21. Please reopen if incase you are still encountering this with the latest version.

        elecharny Emmanuel Lecharny added a comment -

        Closing the resolved issues.


          People

          • Assignee:
            elecharny Emmanuel Lecharny
            Reporter:
            gefm0133 Michael Witzel
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development