Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 10.10.1.1
    • Component/s: Store
    • Labels:
      None
    • Issue & fix info:
      Release Note Needed

      Description

      Some of the error messages for database decryption (DERBY-5792) are not fully internationalized, as they take a hard-coded English message as an argument. We should make the messages come from messages.xml so that they can be localized.

      As discussed in DERBY-5792, we may also want to merge the messages for encryption, re-encryption and decryption to reduce the total number of messages.

      1. d5962-1a.diff
        20 kB
        Knut Anders Hatlen
      2. releaseNote.html
        5 kB
        Knut Anders Hatlen

        Activity

        Rick Hillegas added a comment -

        Thanks, Knut. The release note looks good to me.

        Knut Anders Hatlen added a comment -

        Attaching a first attempt on a release note for this issue.

        Knut Anders Hatlen added a comment -

        Thanks, Rick. Committed revision 1403268.

        Keeping the issue open until a release note has been attached.

        Rick Hillegas added a comment -

        Thanks for the patch, Knut. Looks good to me. +1

        Knut Anders Hatlen added a comment -

        Attaching a patch for this issue.

        The patch removes these messages for decryption failures:

        XBCXX.S: Database decryption failed:

        {0}
        XBCXY.S: Cannot decrypt database because of the database state: {0}

        Instead of passing a detailed message as an argument to those messages, one of the more specific messages for encryption is used. That is, one of these four, depending on the actual failure (they've been adjusted to also mention decryption):

        XBCXO.S: Cannot encrypt, re-encrypt or decrypt the database when there is a global transaction in the prepared state.
        XBCXQ.S: Cannot encrypt, re-encrypt or decrypt a read-only database.
        XBCXS.S: Cannot encrypt, re-encrypt or decrypt a database when it is in the log archive mode.
        XBCXU.S: Encryption, re-encryption or decryption of a database failed:

        {0}

        The above messages were also adjusted to mention re-encryption, so that the following four messages could be removed by the patch:

        XBCXP.S: Cannot re-encrypt the database with a new boot password or an external encryption key when there is a global transaction in the prepared state.
        XBCXR.S: Cannot re-encrypt a read-only database with a new boot password or an external encryption key .
        XBCXT.S: Cannot re-encrypt a database with a new boot password or an external encryption key, when database is in the log archive mode.
        XBCXV.S: Encryption of an encrypted database with a new key or a new password failed: {0}

        Since the removed messages for re-encryption have been replaced with messages that have different SQL states, we would need a release note if we make that change.

        The patch updates the canons for store/encryptDatabaseTest2.sql and store/encryptDatabaseTest3.sql with the new messages. It also adds test cases for decryption to those tests to verify that we get the expected messages.

        All the regression tests passed with the patch.


          People

          • Assignee:
            Knut Anders Hatlen
            Reporter:
            Knut Anders Hatlen
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development