Derby
  1. Derby
  2. DERBY-5737

Remove GenericDescriptorList.elements and replace Enumerator usage with Iterator

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 10.9.1.0
    • Fix Version/s: 10.9.1.0
    • Component/s: SQL
    • Labels:
      None

      Description

      I plan to refactor some of the code for dealing with lists of descriptors. As a first simple step I want to replace the use of Enumeration with Iterator. Later I'm planning to use composition instead of inheritance for the descriptor lists.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        15h 48m 1 Kristian Waagan 03/May/12 09:31
        Gavin made changes -
        Workflow jira [ 12665159 ] Default workflow, editable Closed status [ 12796991 ]
        Kristian Waagan made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Issue & fix info Patch Available [ 10102 ]
        Fix Version/s 10.9.0.0 [ 12316344 ]
        Resolution Fixed [ 1 ]
        Kristian Waagan added a comment -

        Thanks, Knut.
        Committed to trunk with revision 1333356.

        Knut Anders Hatlen added a comment -

        Patch 1a looks like a good improvement. +1

        Kristian Waagan added a comment -

        Regression tests passed.

        Kristian Waagan made changes -
        Field Original Value New Value
        Attachment derby-5737-1a-iterator.diff [ 12525312 ]
        Kristian Waagan added a comment -

        Attaching patch 1a, running regression tests.

        Kristian Waagan created issue -

          People

          • Assignee:
            Kristian Waagan
            Reporter:
            Kristian Waagan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development