Derby
  1. Derby
  2. DERBY-5727

Update POMs to deploy Maven artifacts to repository.apache.org and use ASF parent POM

    Details

      Description

      As per Apache infra's request Maven artifacts should be deployed to repository.apache.org.
      Derby is currently deploying to people.apache.org, for which Maven deployment will be disabled in Jan 2013.

      Additionally, the Derby POMs should refer to the ASF top-level POM as the parent. There are several advantages to doing this, see [1] for details.

      [1] http://www.apache.org/dev/publishing-maven-artifacts.html#inherit-parent

      1. derby-5727-1a-inherit_asf_pom.diff
        11 kB
        Kristian Waagan
      2. derby-5727-1b-inherit_asf_pom.diff
        11 kB
        Kristian Waagan

        Activity

        Kristian Waagan created issue -
        Kristian Waagan made changes -
        Field Original Value New Value
        Status Open [ 1 ] In Progress [ 3 ]
        Kristian Waagan added a comment -

        Attaching patch 1a, which makes the derby-project POM inherit the ASF top-level POM. This makes Maven deploy to repository.apache.org. In addition I've updated the readme file.

        I've tested this once on Solaris 11 with Maven 3.
        It would be nice if PMC members on different platforms could test it too. You can safely test it with a 10.9.0.0_alpha build (trunk), just don't release the temporary repository in Nexus

        Nexus lives at repository.apache.org, log in with your LDAP credentials.
        Patch ready for review.

        Kristian Waagan made changes -
        Attachment derby-5727-1a-inherit_asf_pom.diff [ 12524284 ]
        Kristian Waagan made changes -
        Issue & fix info Patch Available [ 10102 ]
        Kristian Waagan added a comment -

        Attaching patch 1b, which fixes a type and includes some minor changes to the README.
        The patch is now based off the source tree root, and not relative to 'maven2/' (sorry!).

        Kristian Waagan made changes -
        Attachment derby-5727-1b-inherit_asf_pom.diff [ 12525406 ]
        Rick Hillegas added a comment -

        Thanks for the detailed instructions, Kristian. I have successfully followed steps (a-f) in README.txt. I did not follow step (g) because that seemed to be appropriate only after a release has been vetted. Instead, I dropped the alpha artifacts which I had staged at Nexus. I can confirm that the following is possible from my Mac OSX laptop:

        1) I successfully deployed Maven artifacts to my local repository. The artifacts contained the new <parent> element linking them to the top-level POM.

        2) I successfully staged the artifacts on Nexus. Then I dropped them.

        Let me know if there is additional feedback which I can provide on this patch. Thanks.

        Kristian Waagan added a comment -

        Thanks, Rick!

        If you found the instructions sufficient, I think I have what I need from you.
        Just noting that this is a mandated change. It's a bonus that the deploy step seems to have been made less brittle by the change.

        I'll do a quick scan of the release intrstructions on the wiki to see if they need an update.
        Committed patch 1b to trunk with revision 1334874.

        Kristian Waagan made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Issue & fix info Patch Available [ 10102 ]
        Fix Version/s 10.9.0.0 [ 12316344 ]
        Resolution Fixed [ 1 ]
        Kristian Waagan added a comment -

        I updated the wiki page at [1].
        Note that the new POMs haven't been tested on Windows yet. While I expect that they will work, it would be good to get confirmation on that if anyone performs a dry-run on Windows.

        [1] http://wiki.apache.org/db-derby/ReleasePublication

        Kristian Waagan added a comment -

        Closing issue.
        The procedure has been tested on two platforms, and it worked on both of them.
        Bugs or improvements can be logged as separate JIRA issues.

        Kristian Waagan made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Kristian Waagan added a comment -

        I looked into creating artifacts on the older branches. You can do this by copying the built jars from the branch in question, and then build the Maven artifacts from maven2 in trunk. However, since this was such an easy backport, I backported the change to 10.8 (r1336063) and 10.7 (r1336066). It is unlikely that we ever need to publish older builds to Maven, but if the need arise we can do that by running the Maven process from trunk.

        Kristian Waagan made changes -
        Resolution Fixed [ 1 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Kristian Waagan added a comment -

        Closing again.

        Kristian Waagan made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Fix Version/s 10.7.1.4 [ 12315902 ]
        Fix Version/s 10.8.2.3 [ 12318540 ]
        Resolution Fixed [ 1 ]
        Kathey Marsden made changes -
        Fix Version/s 10.8.3.0 [ 12323456 ]
        Fix Version/s 10.8.2.3 [ 12318540 ]
        Gavin made changes -
        Workflow jira [ 12664171 ] Default workflow, editable Closed status [ 12797005 ]

          People

          • Assignee:
            Kristian Waagan
            Reporter:
            Kristian Waagan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development