Derby
  1. Derby
  2. DERBY-5453

Remove unused methods in Cursor and NetCursor

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.9.1.0
    • Fix Version/s: 10.9.1.0
    • Component/s: Network Client
    • Labels:
      None

      Description

      The classes Cursor and NetCursor in the client driver contain many unused methods, most of them for managing the internal byte buffer. These methods should be removed.

      1. d5453.diff
        8 kB
        Knut Anders Hatlen

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        3m 12s 1 Knut Anders Hatlen 10/Oct/11 13:24
        In Progress In Progress Closed Closed
        22h 47m 1 Knut Anders Hatlen 11/Oct/11 12:12
        Gavin made changes -
        Workflow jira [ 12637049 ] Default workflow, editable Closed status [ 12796649 ]
        Knut Anders Hatlen made changes -
        Status In Progress [ 3 ] Closed [ 6 ]
        Issue & fix info Patch Available [ 10102 ]
        Fix Version/s 10.9.0.0 [ 12316344 ]
        Resolution Fixed [ 1 ]
        Knut Anders Hatlen added a comment -

        Thanks, Kristian. Committed revision 1181713.

        Kristian Waagan added a comment -

        Looks like useful cleanup to me. +1

        Knut Anders Hatlen made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Knut Anders Hatlen made changes -
        Field Original Value New Value
        Attachment d5453.diff [ 12498416 ]
        Knut Anders Hatlen added a comment -

        Attaching a patch that removes the unused methods from the two classes. All regression tests passed.

        Knut Anders Hatlen created issue -

          People

          • Assignee:
            Knut Anders Hatlen
            Reporter:
            Knut Anders Hatlen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development