Derby
  1. Derby
  2. DERBY-5396

DRDAStatement and DRDAConnThread swallow IOExceptions

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.8.1.2
    • Fix Version/s: 10.8.2.2, 10.9.1.0
    • Component/s: Network Server
    • Labels:
      None

      Description

      DRDAConnThread.closeStream():

      } catch (IOException e)

      { Util.javaException(e); }

      DRDAStatement.execute():

      } catch (IOException e)

      { Util.javaException(e); }

      Since Util.javaException() only returns an exception, this code doesn't work as intended. The returned exception should also be thrown.

      1. d5396.diff
        2 kB
        Knut Anders Hatlen

        Issue Links

          Activity

          Gavin made changes -
          Workflow jira [ 12630648 ] Default workflow, editable Closed status [ 12801224 ]
          Knut Anders Hatlen made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Myrna van Lunteren made changes -
          Fix Version/s 10.8.2.2 [ 12317968 ]
          Fix Version/s 10.8.2.0 [ 12317955 ]
          Myrna van Lunteren made changes -
          Fix Version/s 10.8.2.0 [ 12317955 ]
          Fix Version/s 10.8.1.6 [ 12316676 ]
          Myrna van Lunteren made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Fix Version/s 10.8.1.6 [ 12316676 ]
          Resolution Fixed [ 1 ]
          Myrna van Lunteren added a comment -

          backported (with some minor manual editing of DRDAConnThread) with revision 1164755.

          Myrna van Lunteren made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Myrna van Lunteren added a comment -

          reopen for backport.

          Knut Anders Hatlen made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Fix Version/s 10.9.0.0 [ 12316344 ]
          Resolution Fixed [ 1 ]
          Knut Anders Hatlen added a comment -

          Thanks, Kathey, the DRDAConnThread part of this issue is the same as DERBY-4350. I'll resolve that issue.

          All the regression tests passed. Committed revision 1163616.

          Knut Anders Hatlen made changes -
          Link This issue is duplicated by DERBY-4350 [ DERBY-4350 ]
          Kathey Marsden added a comment -

          There is issue DERBY-4350 which I am guessing can be closed as a duplicate of this, except that that issue also mentions the lack of logging, which is not addressed with the patch, but that would still be covered by DERBY-1191.

          Knut Anders Hatlen made changes -
          Attachment d5396.diff [ 12492234 ]
          Knut Anders Hatlen added a comment -

          The attached patch makes the suggested changes. Running regression tests now.

          Knut Anders Hatlen made changes -
          Field Original Value New Value
          Status Open [ 1 ] In Progress [ 3 ]
          Knut Anders Hatlen created issue -

            People

            • Assignee:
              Knut Anders Hatlen
              Reporter:
              Knut Anders Hatlen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development