Derby
  1. Derby
  2. DERBY-5394

Reduce chance of OOME with XAMemTest.testDerby4137_TransactionTimeoutSpecifiedNotExceeded in low memory suite

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.9.1.0
    • Fix Version/s: 10.8.2.2, 10.9.1.0
    • Component/s: Test
    • Labels:
      None

      Description

      See thread on derby-dev: "Problems with junit-lowmem" (29th of August 2011).

      The test XAMemTest.testDerby4137_TransactionTimeoutSpecifiedNotExceeded doesn't release all the memory it uses and causes either excessive GC activity (and a much longer run time) or an OOME.

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open In Progress In Progress
          22m 37s 1 Kristian Waagan 29/Aug/11 12:09
          In Progress In Progress Resolved Resolved
          14d 23h 26m 1 Kristian Waagan 13/Sep/11 11:35
          Resolved Resolved Closed Closed
          34d 20h 9m 1 Kristian Waagan 18/Oct/11 07:44
          Gavin made changes -
          Workflow jira [ 12630464 ] Default workflow, editable Closed status [ 12801222 ]
          Knut Anders Hatlen made changes -
          Link This issue is related to DERBY-6114 [ DERBY-6114 ]
          Myrna van Lunteren made changes -
          Fix Version/s 10.8.2.2 [ 12317968 ]
          Fix Version/s 10.8.2.1 [ 12317957 ]
          Kristian Waagan made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Kristian Waagan added a comment -

          Closing issue, no issues seen after the fix was applied.
          The fix committed under this issue was a work-around, not a proper fix addressing the general root cause.

          Myrna van Lunteren made changes -
          Fix Version/s 10.8.2.1 [ 12317957 ]
          Fix Version/s 10.8.2.0 [ 12317955 ]
          Kristian Waagan made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Fix Version/s 10.9.0.0 [ 12316344 ]
          Fix Version/s 10.8.2.0 [ 12317955 ]
          Resolution Fixed [ 1 ]
          Kristian Waagan added a comment -

          Merged fix to the 10.8 branch, hoping there will be another RC.

          I don't plan to do more on this issue now, but for later, and maybe for similar cases, it should be investigated if using a decorator that shuts down the database (and possibly then engine?) addresses the problem.

          Kristian Waagan made changes -
          Attachment derby-5394-1a-execute_last.diff [ 12492058 ]
          Kristian Waagan added a comment -

          Attaching patch 1a, which makes the XAMemTest be executed last in the low-mem suite.

          I've observed a runtime of 46 and 22 minutes for the low-mem suite. It now dropped (back) to around 12 minutes.

          Committed to trunk with revision 1162737.

          Kristian Waagan made changes -
          Field Original Value New Value
          Status Open [ 1 ] In Progress [ 3 ]
          Kristian Waagan created issue -

            People

            • Assignee:
              Kristian Waagan
              Reporter:
              Kristian Waagan
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development