Derby
  1. Derby
  2. DERBY-5361

Document use of URLs with SQLJ.INSTALL_JAR

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 10.9.1.0
    • Fix Version/s: 10.8.2.2, 10.9.1.0
    • Component/s: Documentation
    • Labels:
      None

      Description

      The reference manual's topic on SQLJ.INSTALL_JAR says the first argument is the path of the jar file to add. That argument doesn't have to be a file path, it can also be a URL.

      Changes needed:

      • rename JAR_FILE_PATH to JAR_FILE_URL (or perhaps JAR_FILE_PATH_OR_URL?)
      • update description of said parameter to reflect that it can also take a URL
      • add a new example in the SQL examples paragraph:

      – SQL statement
      – install jar from remote location
      CALL SQLJ.INSTALL_JAR('http://www.example.com/tours.jar', 'APP.Sample3', 0)

      1. rrefstorejarreplace.html
        5 kB
        Kim Haase
      2. DERBY-5361-3.diff
        0.5 kB
        Kim Haase
      3. DERBY-5361-2.zip
        4 kB
        Kim Haase
      4. DERBY-5361-2.diff
        3 kB
        Kim Haase
      5. DERBY-5361.zip
        4 kB
        Kim Haase
      6. DERBY-5361.stat
        0.1 kB
        Kim Haase
      7. DERBY-5361.diff
        3 kB
        Kim Haase

        Activity

        Hide
        Kim Haase added a comment -

        This fix also affects the REPLACE_JAR topic.

        Show
        Kim Haase added a comment - This fix also affects the REPLACE_JAR topic.
        Hide
        Kim Haase added a comment -

        Attaching DERBY-5361.diff, DERBY-5361.stat, and DERBY-5361.zip, with these changes:

        M src/ref/rrefstorejarinstall.dita
        M src/ref/rrefstorejarreplace.dita

        Hope this is what you had in mind? Thanks in advance.

        Show
        Kim Haase added a comment - Attaching DERBY-5361 .diff, DERBY-5361 .stat, and DERBY-5361 .zip, with these changes: M src/ref/rrefstorejarinstall.dita M src/ref/rrefstorejarreplace.dita Hope this is what you had in mind? Thanks in advance.
        Hide
        Dag H. Wanvik added a comment -

        Thanks, Kim! Looks good except for this wording in both topics:

        "The path (or URL) and physical name":

        I think the old wording "path and physical name" is a clumsy way of saying directory name + file name. Usually a "path" includes both.
        In any case, "a URL and physical name" is wrong, I think. I suggest replacing this with something like:

        "A path (including both directory and file name) or a URL"

        Show
        Dag H. Wanvik added a comment - Thanks, Kim! Looks good except for this wording in both topics: "The path (or URL) and physical name": I think the old wording "path and physical name" is a clumsy way of saying directory name + file name. Usually a "path" includes both. In any case, "a URL and physical name" is wrong, I think. I suggest replacing this with something like: "A path (including both directory and file name) or a URL"
        Hide
        Kim Haase added a comment -

        Thanks, Dag!

        The first example in http://db.apache.org/derby/docs/dev/ref/rrefstorejarinstall.html doesn't actually have a directory name, so I guess that is required only if the file is not in the current directory. Would it make sense to add another example similar to the example for REPLACE_JAR, which does use the directory name?

        Show
        Kim Haase added a comment - Thanks, Dag! The first example in http://db.apache.org/derby/docs/dev/ref/rrefstorejarinstall.html doesn't actually have a directory name, so I guess that is required only if the file is not in the current directory. Would it make sense to add another example similar to the example for REPLACE_JAR, which does use the directory name?
        Hide
        Dag H. Wanvik added a comment -

        Yes, I think so, as long as we don't phrase it so it looks like we require an absolute path, relative (including just the file name, i.e. no directory) works too.

        Show
        Dag H. Wanvik added a comment - Yes, I think so, as long as we don't phrase it so it looks like we require an absolute path, relative (including just the file name, i.e. no directory) works too.
        Hide
        Kim Haase added a comment -

        Thanks, Dag! Well, "directory and file name" can mean both absolute and relative, so I hope this new patch works all right. Attaching DERBY-5361-2.diff and DERBY-5361-2.zip.

        Show
        Kim Haase added a comment - Thanks, Dag! Well, "directory and file name" can mean both absolute and relative, so I hope this new patch works all right. Attaching DERBY-5361 -2.diff and DERBY-5361 -2.zip.
        Hide
        Dag H. Wanvik added a comment -

        Looks good to me! +1

        Show
        Dag H. Wanvik added a comment - Looks good to me! +1
        Hide
        Kim Haase added a comment -

        Thanks again, Dag – I'll commit this tomorrow.

        Show
        Kim Haase added a comment - Thanks again, Dag – I'll commit this tomorrow.
        Hide
        Kim Haase added a comment -

        Committed patch DERBY-5361-2.diff to documentation trunk at revision 1153117.
        Merged to 10.8 doc branch at revision 1153132.

        Show
        Kim Haase added a comment - Committed patch DERBY-5361 -2.diff to documentation trunk at revision 1153117. Merged to 10.8 doc branch at revision 1153132.
        Hide
        Knut Anders Hatlen added a comment -

        Thanks, the updated topics look good.

        One tiny issue... The comment in the REPLACE_JAR example says:

        – SQL statement
        – replace a jar at a remote location

        That sounded (to me) like it's the jar at the remote location that is being replaced by something, whereas it is actually the jar in the database that is being replaced by the jar at the remote location. Perhaps "replacement jar at a remote location" would be more accurate?

        Show
        Knut Anders Hatlen added a comment - Thanks, the updated topics look good. One tiny issue... The comment in the REPLACE_JAR example says: – SQL statement – replace a jar at a remote location That sounded (to me) like it's the jar at the remote location that is being replaced by something, whereas it is actually the jar in the database that is being replaced by the jar at the remote location. Perhaps "replacement jar at a remote location" would be more accurate?
        Hide
        Kim Haase added a comment -

        Reopen for fix noticed by Knut.

        Show
        Kim Haase added a comment - Reopen for fix noticed by Knut.
        Hide
        Kim Haase added a comment -

        Thanks, Knut, for catching this confusing language. Maybe it would be clearest to say

        replace jar from remote location

        since the corresponding INSTALL_JAR comment is "install jar from remote location".

        What do you think?

        Show
        Kim Haase added a comment - Thanks, Knut, for catching this confusing language. Maybe it would be clearest to say replace jar from remote location since the corresponding INSTALL_JAR comment is "install jar from remote location". What do you think?
        Hide
        Knut Anders Hatlen added a comment -

        That sounds fine. +1

        Show
        Knut Anders Hatlen added a comment - That sounds fine. +1
        Hide
        Kim Haase added a comment -

        Thanks, Knut. I'm attaching DERBY-5361-3.diff and rrefstorejarreplace.html, with the suggested change. Hope this is satisfactory.

        Show
        Kim Haase added a comment - Thanks, Knut. I'm attaching DERBY-5361 -3.diff and rrefstorejarreplace.html, with the suggested change. Hope this is satisfactory.
        Hide
        Knut Anders Hatlen added a comment -

        Looks great! +1

        Show
        Knut Anders Hatlen added a comment - Looks great! +1
        Hide
        Kim Haase added a comment -

        Thanks again, Knut, for your review.

        Committed patch DERBY-5361-3.diff to documentation trunk at revision 1160687.
        Merged to 10.8 doc branch at revision 1160697.

        Show
        Kim Haase added a comment - Thanks again, Knut, for your review. Committed patch DERBY-5361 -3.diff to documentation trunk at revision 1160687. Merged to 10.8 doc branch at revision 1160697.
        Hide
        Knut Anders Hatlen added a comment -

        I've verified the fix, so I'm closing the issue.

        Show
        Knut Anders Hatlen added a comment - I've verified the fix, so I'm closing the issue.

          People

          • Assignee:
            Kim Haase
            Reporter:
            Knut Anders Hatlen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development