Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.9.1.0
    • Fix Version/s: 10.9.1.0
    • Component/s: Test
    • Labels:
      None
    • Environment:
      phoneME
    • Bug behavior facts:
      Regression Test Failure

      Description

      I see this failure on phoneME:

      org.apache.derbyTesting.functionTests.tests.tools.ToolScripts.URLCheck (from org.apache.derbyTesting.functionTests.suites.All)
      junit.framework.ComparisonFailure: Output at line 19 expected:<[ij(CONNECTION1)> -- Find an unknown attribute.]> but was:<[JAVA ERROR: java.lang.NoClassDefFoundError: java.sql.Driver]>
      at org.apache.derbyTesting.functionTests.util.CanonTestCase.compareCanon(Unknown Source)
      at org.apache.derbyTesting.functionTests.util.ScriptTestCase.runTest(Unknown Source)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(Unknown Source)
      at junit.extensions.TestDecorator.basicRun(Unknown Source)
      at junit.extensions.TestSetup$1.protect(Unknown Source)
      at junit.extensions.TestSetup.run(Unknown Source)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(Unknown Source)
      at sun.misc.CVM.runMain(Unknown Source)

      The original test was excluded on Foundation because it required java.sql.Driver.

      1. d5345.diff
        1 kB
        Knut Anders Hatlen

        Issue Links

          Activity

          Knut Anders Hatlen created issue -
          Knut Anders Hatlen made changes -
          Field Original Value New Value
          Link This issue is broken by DERBY-5303 [ DERBY-5303 ]
          Knut Anders Hatlen made changes -
          Assignee Knut Anders Hatlen [ knutanders ]
          Knut Anders Hatlen added a comment -

          The attached patch makes ToolScripts run the URLCheck test case only when the platform supports JDBC 3, which matches the behaviour before the test was converted to JUnit.

          Knut Anders Hatlen made changes -
          Attachment d5345.diff [ 12487124 ]
          Knut Anders Hatlen added a comment -

          Committed revision 1148657.

          Knut Anders Hatlen made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Fix Version/s 10.9.0.0 [ 12316344 ]
          Resolution Fixed [ 1 ]
          Bryan Pendleton added a comment -

          Thank you!

          Gavin made changes -
          Workflow jira [ 12621077 ] Default workflow, editable Closed status [ 12801175 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          25m 31s 1 Knut Anders Hatlen 20/Jul/11 10:01

            People

            • Assignee:
              Knut Anders Hatlen
              Reporter:
              Knut Anders Hatlen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development