Derby
  1. Derby
  2. DERBY-5276

Reference manual has wrong length for BIGINT columns in system tables

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 10.9.1.0
    • Fix Version/s: 10.8.2.2, 10.9.1.0
    • Component/s: Documentation
    • Labels:
      None

      Description

      The description of the SYSCOLUMNS table at http://db.apache.org/derby/docs/dev/ref/rrefsistabs22441.html says that the BIGINT columns AUTOINCREMENTVALUE, AUTOINCREMENTSTART and AUTOINCREMENTINC have length 19. The maximum length of a BIGINT is 20 (when including the sign for negative values). Here's an example that shows that these columns can hold values whose length is 20:

      ij> create table t(x bigint not null generated always as identity (start with -1234567890123456789, increment by -1234567890123456789));
      0 rows inserted/updated/deleted
      ij> select autoincrementvalue, autoincrementstart, autoincrementinc from sys.syscolumns where columnname='X';
      AUTOINCREMENTVALUE |AUTOINCREMENTSTART |AUTOINCREMENTINC
      --------------------------------------------------------------
      -1234567890123456789|-1234567890123456789|-1234567890123456789

      1 row selected

      Other places where BIGINT columns are listed with length 19:

      SYSCONGLOMERATES - http://db.apache.org/derby/docs/dev/ref/rrefsistabs39391.html
      SYSFILES - http://db.apache.org/derby/docs/dev/ref/rrefsistabs40972.html
      SYSSEQUENCES - http://db.apache.org/derby/docs/dev/ref/rrefsistabssyssequences.html
      SYSXPLAIN_RESULTSET_TIMINGS - http://db.apache.org/derby/docs/dev/ref/rrefsysxplain_resultset_timings.html
      SYSXPLAIN_STATEMENT_TIMINGS - http://db.apache.org/derby/docs/dev/ref/rrefsysxplain_statement_timings.html
      SYSCS_DIAG.SPACE_TABLE - http://db.apache.org/derby/docs/dev/ref/rrefsyscsdiagtables.html

      I haven't verified if negative values are allowed in all of these columns. If they are only allowed to hold non-negative values, should we keep the value 19? Or should we change all to 20 for consistency? I'm assuming that "length" in these tables refers to the display size of the columns.

      1. derby5276-ref.diff
        11 kB
        Jayaram Subramanian
      2. derby5276.stat
        0.3 kB
        Kim Haase
      3. derby5276.zip
        19 kB
        Kim Haase

        Activity

        Jayaram Subramanian added a comment -

        Hi Knut
        I would like to take up this reference manual updation. Please let me know on how to proceed.

        Kim Haase added a comment -

        To work on a documentation issue, follow the instructions in http://db.apache.org/derby/manuals/dita.html. (Note: the correct toolkit version is a bit hard to find now – you might have to Google for it.)

        The review and commit mechanism is similar to the one for code. For examples, look at some recently resolved documentation issues such as https://issues.apache.org/jira/browse/DERBY-5226 and https://issues.apache.org/jira/browse/DERBY-5212.

        Feel free to ask if you have any questions. We welcome your help!

        Rick Hillegas added a comment -

        I vote for consistency: bump all of the BIGINT lengths to 20. Certainly the SYSSEQUENCES columns can hold negative BIGINTs. For numeric columns in the catalogs, length seems to refer to the max number of characters needed to display the column value.

        Jayaram Subramanian added a comment -

        Attaching the patch with modified dita files. When i tried to generate the html output i got a out of memory error because of which i was not able to test the final output.

        BUILD FAILED
        C:\derby-documentation\trunk\build.xml:108: The following error occurred while e
        xecuting this line:
        C:\derby-documentation\trunk\build.xml:146: The following error occurred while e
        xecuting this line:
        C:\derby-documentation\trunk\DITA-OT1.1.2.1\pretargets.xml:100: java.lang.OutOfM
        emoryError: Java heap space

        Rick Hillegas added a comment -

        Hi Jayaram,

        To avoid the out of memory error, see item 4 in the instructions at http://db.apache.org/derby/manuals/dita.html#Setting+up+your+environment . I find that I am able to build the documentation when I set

        export ANT_OPTS="-Xmx512m"

        Hope this helps,
        -Rick

        Kim Haase added a comment -

        This patch looks fine, and I'll commit it. Thanks for working on it!

        I'm also attaching derby5276.stat, a stat file showing the changes, and derby5276.zip, a zip file with the generated HTML, as is customary.

        Normally, as you may have noticed, we attach those two files at the same time as the patch file, and we don't file a patch until we are sure that the docs build correctly. In this case I've confirmed that the patch is correct.

        Kim Haase added a comment -

        Committed patch derby5276-ref.diff to documentation trunk at revision 1154270.
        Merged to 10.8 doc branch at revision 1154287.

        Knut Anders Hatlen added a comment -

        Verified that the reported problems have been fixed. Closing the issue.

        Thanks, Jayaram!


          People

          • Assignee:
            Jayaram Subramanian
            Reporter:
            Knut Anders Hatlen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development