Derby
  1. Derby
  2. DERBY-5215

Localize messages introduced or changed in 10.7 and 10.8

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.8.2.2
    • Fix Version/s: 10.8.2.2, 10.9.1.0
    • Component/s: Localization
    • Labels:
      None

      Description

      Localize the message changes from the recent 10.7 and 10.8 feature releases.

      1. ShowMessageChanges.java
        13 kB
        Rick Hillegas
      2. show-message-changes
        0.3 kB
        Dag H. Wanvik
      3. NewPropertyFileVTI.java
        4 kB
        Rick Hillegas
      4. NewPropertyFileVTI.java
        4 kB
        Rick Hillegas
      5. derby-5215-01-ab-localizationChanges.diff
        255 kB
        Rick Hillegas
      6. derby-5215-01-aa-localizationChanges.diff
        255 kB
        Rick Hillegas
      7. changes.html
        13 kB
        Rick Hillegas

        Activity

        Rick Hillegas added a comment -

        Attaching changes.html, a page describing the messages introduced or changed since 10.6.

        Rick Hillegas added a comment -

        Attaching a table function (NewPropertyFileVTI) and a program which drives it, ShowMessageChanges. The ShowMessageChanges program can be used to show the message changes between one Derby branch and another. It can be used by people who want to vet the new localizations which I am about to attach. ShowMessageChanges produces an html report for a particular locale, detailing which messages are new, which have changed, and which have been deleted. Here is its usage diagnostic:

        Usage:

        java ShowMessageChanges $newCodeline $oldCodeline $locale

        where

        $newCodeline = path to root of subversion codeline for the new codeline, e.g. "/Users/me/derby/10.9"
        $oldCodeline = path to root of subversion codeline for the old codeline, e.g. "/Users/me/derby/10.6"
        $locale = name of locale, e.g. "de_DE"

        This will output a summary of the changes to showMessages.html

        Rick Hillegas added a comment - - edited

        The translators have handed back message localizations for the message changes in 10.7 and 10.8. I am attaching the result: derby-5215-01-aa-localizationChanges.diff

        In vetting these changes, you may find the attached ShowMessageChanges program useful. Touches the following files:

        M java/tools/org/apache/derby/loc/toolsmessages_ja_JP.properties
        M java/tools/org/apache/derby/loc/toolsmessages_zh_TW.properties
        M java/tools/org/apache/derby/loc/toolsmessages_de_DE.properties
        M java/tools/org/apache/derby/loc/toolsmessages_zh_CN.properties
        M java/tools/org/apache/derby/loc/toolsmessages_ko_KR.properties
        M java/tools/org/apache/derby/loc/toolsmessages_es.properties
        M java/tools/org/apache/derby/loc/toolsmessages_fr.properties
        M java/engine/org/apache/derby/loc/messages_de_DE.properties
        M java/engine/org/apache/derby/loc/messages_zh_CN.properties
        M java/engine/org/apache/derby/loc/messages_ko_KR.properties
        M java/engine/org/apache/derby/loc/messages_es.properties
        M java/engine/org/apache/derby/loc/messages_fr.properties
        M java/engine/org/apache/derby/loc/messages_it.properties
        M java/engine/org/apache/derby/loc/messages_ja_JP.properties
        M java/engine/org/apache/derby/loc/messages_zh_TW.properties
        M java/drda/org/apache/derby/loc/drda/messages_zh_CN.properties
        M java/drda/org/apache/derby/loc/drda/messages_ko_KR.properties
        M java/drda/org/apache/derby/loc/drda/messages_it.properties
        M java/drda/org/apache/derby/loc/drda/messages_ja_JP.properties
        M java/drda/org/apache/derby/loc/drda/messages_zh_TW.properties

        Dag H. Wanvik added a comment - - edited

        Hi Rick, I gave the tool a test run, worked for me. Cool! Question: it doesn't show me the baseline, i.e. what messages have changed in the default locale (at least en_US didn't work). What is the easiest way to show the baseline changes? But I see you have attached changes.html for those..
        I know I can diff messages.xml etc, of course, but it would be nice of the tool could show those as well?

        Dag H. Wanvik added a comment -

        Btw, I added an import statement to NewPropertyFileVTI to make it compile outside the superclass package.
        Uploading a bash script I made to run it for convenience (it presupposes the class files live next to the script in the same directory).

        Rick Hillegas added a comment -

        Thanks for taking a look at the new localizations and the tool, Dag. And thanks for finding that compile-time problem with the table function. I am attaching a new version of the table function which hopefully fixes that.

        The short answer to your question about the changes to the English master files is this: just view the attached changes.html file.

        The long answer to your question is that it would require a little jiggery-pokery to make ShowMessageChanges handle the en locale correctly. This is because the English engine messages live in a generated messages_en.properties file. In 10.6, that file is generated into the source tree. In 10.7 and later, that file is generated into the special directory tree which the build creates for generated sources.

        Dag H. Wanvik added a comment -

        DId a spot check on Spanish locale: Looks good.
        Nit:
        Spanish has this Engine messages as changed:

        XCL16.S

        while the uploaded change.html (English) does not have this change.
        English has the following two as deleted, no such notice in the Spanish
        version as generated:

        XCL16.S.0
        XCL16.S.1

        So, it seems, thw two versions were merged into one: XCL16.S, which
        means that the Spanish report is somewhat misleading.. but good
        enough since this report is just intended for us vetters anyway..

        Dag H. Wanvik added a comment -

        Seems the bundle does not have new translations for Czech, Russian, Hungarian, Polish and Portuguese Brazilian Portuguese. Is this expected?

        Rick Hillegas added a comment -

        Thanks for continuing to look at the patch, Dag. I will try to understand the issue with the Spanish locale after lunch. Concerning the missing languages: we haven't been keeping those locales up to date for several releases now. The locales we've tried to keep evergreen are:

        Chinese (simplified)
        Chinese (traditional)
        French
        German
        Italian
        Japanese
        Korean
        Spanish

        Thanks,
        -Rick

        Rick Hillegas added a comment -

        Attaching a second rev of the localization changes. I found that the first rev failed to build when applied to a clean workspace. There were many instances of the following error in the French and Italian messages:

        java.lang.AssertionError: Lone single-quote in message BLAHMESSAGEID in blahfilename
        This is OK if it is used for quoting special characters in the message. If this is what the character is used for, add an exception in org.apache.derbyBuild.MessageVetter.LONE_QUOTE_ALLOWED.

        I added extra single quotes to the offending messages.

        I notice that when I run ShowMessageChanges on the French locale, I see a lot of spurious changes. I think these are caused by the fixes to single quotes added as part of DERBY-4796.

        Rick Hillegas added a comment -

        Hi Dag,

        Hope we're not talking past one another with respect to the Spanish messages. When I run ShowMessageChanges on the es locale, I see XCL16.S as a new Spanish engine message and XCL16.S.0 and XCL16.S.1 as deleted. This agrees with what I expect from changes.html. Thanks.

        Dag H. Wanvik added a comment -

        I found out why I saw something else: I ran it on trunk vs 10.7, sorry about. If you do, you'll see:

        XCL16.S

        ResultSet no se ha abierto. La operación ''

        {0}'' no está permitida. Compruebe que autocommit esté desactivado.
        vs.
        ResultSet no abierto. Operación ''{0}

        '' no permitida. Verifique que AutoCommit sea OFF.

        Rick Hillegas added a comment -

        Committed derby-5215-01-ab-localizationChanges.diff at subversion revision 1135568.

        Rick Hillegas added a comment -

        Ported 1135568 from trunk to 10.8 branch at subversion revision 1135580.

        Rick Hillegas added a comment -

        Resolving this issue now that the localizations have been applied to the 10.8 branch. This issue can be re-opened if we find problems with these localizations--or follow-on bugs can be filed.


          People

          • Assignee:
            Rick Hillegas
            Reporter:
            Rick Hillegas
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development