Derby
  1. Derby
  2. DERBY-5199

Assert failure in AutomaticIndexStatisticsMultiTest.testMTSelectWithDDL()

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 10.8.1.2
    • Fix Version/s: None
    • Component/s: Services
    • Labels:
      None
    • Environment:
      FreeBSD 8.2 i386 running inside VirtualBox
      OpenJDK 6 b20

      Description

      I saw this failure with the 10.8.1.2 release candidate:

      junit.framework.AssertionFailedError: failed to get statistics for table MTSEL (#expected=2, timeout=0)
      Index statistics for MTSEL
      : <no stats>
      expected:<2> but was:<0>
      at org.apache.derbyTesting.junit.IndexStatsUtil.getStatsTable(IndexStatsUtil.java:236)
      at org.apache.derbyTesting.functionTests.tests.store.AutomaticIndexStatisticsMultiTest.verifyStatistics(AutomaticIndexStatisticsMultiTest.java:143)
      at org.apache.derbyTesting.functionTests.tests.store.AutomaticIndexStatisticsMultiTest.testMTSelectWithDDL(AutomaticIndexStatisticsMultiTest.java:135)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:112)

      It may be the same underlying bug as DERBY-5097, but I'm filing a separate report since this happened in a different test case.

        Issue Links

          Activity

          Knut Anders Hatlen created issue -
          Knut Anders Hatlen made changes -
          Field Original Value New Value
          Link This issue relates to DERBY-5097 [ DERBY-5097 ]
          Myrna van Lunteren added a comment -

          Changes went in for DERBY-5097 in early June. Has this issue been seen since?
          If not, I'd like to see this closed as either a duplicate, or cannot reproduce...

          Knut Anders Hatlen made changes -
          Link This issue duplicates DERBY-5097 [ DERBY-5097 ]
          Knut Anders Hatlen made changes -
          Link This issue relates to DERBY-5097 [ DERBY-5097 ]
          Knut Anders Hatlen added a comment -

          I don't think this failure was seen more than once. Closing as a duplicate on the assumption that it's just a different manifestation of DERBY-5097.

          Knut Anders Hatlen made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Duplicate [ 3 ]
          Gavin made changes -
          Workflow jira [ 12610968 ] Default workflow, editable Closed status [ 12801147 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          71d 15h 14m 1 Knut Anders Hatlen 30/Jun/11 11:19

            People

            • Assignee:
              Unassigned
              Reporter:
              Knut Anders Hatlen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development