Derby
  1. Derby
  2. DERBY-5117

ParameterMetaDataJdbc30Test fails with "'DUMMYINT' is not recognized as a function or procedure"

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.8.1.2
    • Fix Version/s: 10.8.1.2
    • Component/s: Test
    • Labels:
      None
    • Bug behavior facts:
      Regression Test Failure

      Description

      ParameterMetaDataJdbc30Test has failed a couple of times in the nightly tests on Java 7.

      http://dbtg.foundry.sun.com/derby/test/Daily/jvm1.7/testing/testlog/lin/1078310-suitesAll_diff.txt

      1) testMetatdataAfterProcRecompile(org.apache.derbyTesting.functionTests.tests.jdbcapi.ParameterMetaDataJdbc30Test)java.sql.SQLSyntaxErrorException: 'DUMMYINT' is not recognized as a function or procedure.
      at org.apache.derby.impl.jdbc.SQLExceptionFactory40.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.generateCsSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.ConnectionChild.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedPreparedStatement.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedCallableStatement.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedCallableStatement20.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedCallableStatement30.<init>(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedCallableStatement40.<init>(Unknown Source)
      at org.apache.derby.jdbc.Driver40.newEmbedCallableStatement(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.prepareCall(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.prepareCall(Unknown Source)
      at org.apache.derbyTesting.junit.BaseJDBCTestCase.prepareCall(BaseJDBCTestCase.java:317)
      at org.apache.derbyTesting.functionTests.tests.jdbcapi.ParameterMetaDataJdbc30Test.testMetatdataAfterProcRecompile(ParameterMetaDataJdbc30Test.java:524)

      1. derby-5117-1a.diff
        2 kB
        Knut Anders Hatlen

        Activity

        Knut Anders Hatlen added a comment -

        The procedure DUMMYINT is

        • created by testCallableStatement, but not dropped
        • called, dropped and created by testMetatdataAfterProcRecompile

        If testMetatdataAfterProcRecompile runs before testCallableStatement, it fails because it cannot find the DUMMYINT procedure.

        Knut Anders Hatlen added a comment -

        The attached patch makes testCallableStatement drop the procedure when it's done, and testMetatdataAfterProcRecompile create the procedure as its first step and drop it when it's done.

        Knut Anders Hatlen added a comment -

        Committed revision 1079779.


          People

          • Assignee:
            Knut Anders Hatlen
            Reporter:
            Knut Anders Hatlen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development