Derby
  1. Derby
  2. DERBY-5052

[patch] Bad name collision causes non functional method

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 10.7.1.1
    • Fix Version/s: 10.8.1.2
    • Component/s: Tools
    • Labels:
      None
    • Urgency:
      Low
    • Bug behavior facts:
      Deviation from standard

      Description

      ijMultipleResultSetResult has this method

      /**

      • Create a ijResultImpl that represents multiple result set.
        */
        public ijMultipleResultSetResult(List resultSets) throws SQLException { resultSets = new ArrayList(); resultSets.addAll(resultSets); }

      due to the name collision, this does nothing... patch fixes with this. prefixing.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        14h 18m 1 Knut Anders Hatlen 18/Feb/11 21:08
        Resolved Resolved Closed Closed
        2h 54m 1 Dave Brosius 19/Feb/11 00:03
        Gavin made changes -
        Workflow jira [ 12599273 ] Default workflow, editable Closed status [ 12797971 ]
        Rick Hillegas made changes -
        Fix Version/s 10.8.1.2 [ 12316362 ]
        Fix Version/s 10.8.1.1 [ 12316356 ]
        Rick Hillegas made changes -
        Fix Version/s 10.8.1.1 [ 12316356 ]
        Fix Version/s 10.8.1.0 [ 12315561 ]
        Dave Brosius made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Bug behavior facts [Deviation from standard]
        Knut Anders Hatlen made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Bug behavior facts [Regression]
        Assignee Dave Brosius [ dbrosius@apache.org ]
        Resolution Fixed [ 1 ]
        Knut Anders Hatlen added a comment -

        Thanks for the patch, Dave!

        I went a bit further and removed the buggy constructor, since it's not called anywhere in the code.

        Committed revision 1072148.

        Dave Brosius made changes -
        Field Original Value New Value
        Attachment bad_name_collision.diff [ 12471369 ]
        Dave Brosius created issue -

          People

          • Assignee:
            Dave Brosius
            Reporter:
            Dave Brosius
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1h
              1h
              Remaining:
              Remaining Estimate - 1h
              1h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development