Derby
  1. Derby
  2. DERBY-5033

[patch] System.arraycopy, being native, is more performant

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 10.7.1.1
    • Fix Version/s: 10.8.1.2
    • Component/s: Network Client
    • Labels:
      None
    • Urgency:
      Low
    • Bug behavior facts:
      Performance

      Description

      various places in the code, manual loops are used to copy one array to another, switch with System.arraycopy for better performance.

      1. use_arraycopy.diff
        4 kB
        Dave Brosius
      2. use_arraycopy_2.diff
        4 kB
        Knut Anders Hatlen

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        2d 14h 42m 1 Knut Anders Hatlen 14/Feb/11 21:40
        Resolved Resolved Closed Closed
        2d 4h 1m 1 Dave Brosius 17/Feb/11 01:42
        Gavin made changes -
        Workflow jira [ 12552805 ] Default workflow, editable Closed status [ 12800985 ]
        Rick Hillegas made changes -
        Fix Version/s 10.8.1.2 [ 12316362 ]
        Fix Version/s 10.8.1.1 [ 12316356 ]
        Rick Hillegas made changes -
        Fix Version/s 10.8.1.1 [ 12316356 ]
        Fix Version/s 10.8.1.0 [ 12315561 ]
        Dave Brosius made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Bug behavior facts [Performance]
        Knut Anders Hatlen made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Issue & fix info [Patch Available]
        Assignee Dave Brosius [ dbrosius@apache.org ]
        Resolution Fixed [ 1 ]
        Knut Anders Hatlen added a comment -

        Regression tests passed. Committed revision 1070677.

        Knut Anders Hatlen made changes -
        Attachment use_arraycopy_2.diff [ 12471014 ]
        Knut Anders Hatlen added a comment -

        Thanks, Dave. This looks like a good simplification of the code. One of the arraycopy() calls in DecryptionManager was added without removing the corresponding loop. Attaching an updated patch (use_arraycopy_2.diff) that also removes the loop.

        Running regression tests now.

        Dave Brosius made changes -
        Field Original Value New Value
        Attachment use_arraycopy.diff [ 12470933 ]
        Dave Brosius created issue -

          People

          • Assignee:
            Dave Brosius
            Reporter:
            Dave Brosius
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1h
              1h
              Remaining:
              Remaining Estimate - 1h
              1h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development