Derby
  1. Derby
  2. DERBY-5023

Cannot find Ant libraries when building from NetBeans

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 10.7.1.1
    • Fix Version/s: 10.8.1.2
    • Component/s: Build tools
    • Labels:
      None

      Description

      Building Derby doesn't work out of the box in NetBeans. The wiki page http://wiki.apache.org/db-derby/BuildingDerby instructs NetBeans users to specify the ant.library.dir property in order to get the build working.

      The Ant documentation says the following about the ant.library.dir property: "The following property is only set if Ant is started via the Launcher class (which means it may not be set inside IDEs either)" - http://ant.apache.org/manual/properties.html

      Since the property is not guaranteed to be set, I suggest that we replace references to "$

      {ant.library.dir}

      /ant.jar" with references to "$

      {ant.core.lib}

      " in the build scripts. According to the above mentioned Ant manual page the ant.core.lib property should always be available and point to ant.jar. Changing this makes it possible to build Derby from NetBeans with no special customization.

      1. properties.diff
        1 kB
        Knut Anders Hatlen

        Activity

        Mamta A. Satoor added a comment -

        I ran into same problem because I was using ant 1.6.5, I upgraded ant to 1.7 and that has resolved the problem

        Knut Anders Hatlen added a comment -

        Oops... This change seems to have broken the build in the Tinderbox: http://dbtg.foundry.sun.com/derby/test/tinderbox_trunk16/UpdateInfo/1070502-buildDetails.txt

        I can reproduce this build break using Ant 1.6.5. BUILDING.html however states that Ant 1.7.0 or newer is required, so I'll check which version is used by the Tinderbox and update it if needed.

        Knut Anders Hatlen added a comment -

        Committed revision 1070501.

        Knut Anders Hatlen added a comment -

        Updated the description with the URL to the Ant manual that was cited.

        Knut Anders Hatlen added a comment -

        Attaching patch to fix this issue.


          People

          • Assignee:
            Knut Anders Hatlen
            Reporter:
            Knut Anders Hatlen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development