Derby
  1. Derby
  2. DERBY-5020

[patch] remove redundant finalizer methods

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 10.7.1.1
    • Fix Version/s: 10.8.1.2
    • Component/s: Network Client
    • Labels:
      None
    • Urgency:
      Low
    • Bug behavior facts:
      Performance

      Description

      code implements a finalize method by just calling super.finalize. Having a finalizer makes the work of the gc harder than if you didn't have it at all, so remove it.

        Activity

        Knut Anders Hatlen added a comment -

        We did see some performance issues on the embedded driver before that were caused by EmbedResultSet overriding finalize(), so I think this would be good to get fixed. Thanks, Dave!

        Committed revision 1069760.


          People

          • Assignee:
            Dave Brosius
            Reporter:
            Dave Brosius
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1h
              1h
              Remaining:
              Remaining Estimate - 1h
              1h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development