Derby
  1. Derby
  2. DERBY-4868

Remove Types.BIT/Types.BOOLEAN switch in JVMInfo

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 10.7.1.1
    • Fix Version/s: 10.7.1.1
    • Component/s: SQL
    • Labels:
      None

      Description

      JVMInfo contains code to switch between using Types.BIT and Types.BOOLEAN based on the JVM version. This was needed when we supported Java 1.3, since Types.BOOLEAN was introduced in Java 1.4 and so Types.BIT had to be used instead on old platforms. Currently, all supported JDBC versions (including JSR-169 for small devices) have Types.BOOLEAN, so the code is no longer needed.

      1. bit-boolean.diff
        3 kB
        Knut Anders Hatlen

        Activity

        Knut Anders Hatlen created issue -
        Knut Anders Hatlen made changes -
        Field Original Value New Value
        Assignee Knut Anders Hatlen [ knutanders ]
        Knut Anders Hatlen made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Knut Anders Hatlen added a comment -

        The attached patch removes the code that initializes the field JAVA_SQL_TYPES_BOOLEAN in JVMInfo, since it's always initialized to Types.BOOLEAN. It also makes BaseTypeIdImpl use Types.BOOLEAN directly instead of the field from JVMInfo.

        Knut Anders Hatlen made changes -
        Attachment bit-boolean.diff [ 12458150 ]
        Knut Anders Hatlen added a comment -

        All the regression tests ran cleanly with the patch.

        Knut Anders Hatlen made changes -
        Fix Version/s 10.7.1.0 [ 12314971 ]
        Affects Version/s 10.7.1.0 [ 12314971 ]
        Issue & fix info [Patch Available]
        Knut Anders Hatlen added a comment -

        Committed revision 1028645.

        Knut Anders Hatlen made changes -
        Issue & fix info [Patch Available]
        Fix Version/s 10.7.1.0 [ 12314971 ]
        Resolution Fixed [ 1 ]
        Status In Progress [ 3 ] Closed [ 6 ]
        Rick Hillegas made changes -
        Affects Version/s 10.7.1.1 [ 12315564 ]
        Affects Version/s 10.7.1.0 [ 12314971 ]
        Fix Version/s 10.7.1.1 [ 12315564 ]
        Fix Version/s 10.7.1.0 [ 12314971 ]
        Gavin made changes -
        Workflow jira [ 12525333 ] Default workflow, editable Closed status [ 12800237 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        3m 24s 1 Knut Anders Hatlen 27/Oct/10 13:52
        In Progress In Progress Closed Closed
        1d 19h 56m 1 Knut Anders Hatlen 29/Oct/10 09:49

          People

          • Assignee:
            Knut Anders Hatlen
            Reporter:
            Knut Anders Hatlen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development