Derby
  1. Derby
  2. DERBY-4860

RunSuite on derbylang and other subsuites fails with java.lang.NoClassDefFoundError because of prepended ^

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 10.5.3.0
    • Fix Version/s: 10.5.3.2, 10.6.2.4, 10.7.1.1
    • Component/s: Test
    • Labels:
      None

      Description

      -Djvmflags works fine when run RunTest or with RunSuite and derbyall, but with derbylang, derbtools and other subsuites it fails as follows, because it prepends ^ inappropriately to the options when launching the process.

      java -Dverbose=true -Djvmflags="-Xgcpolicy:optthruput^-Xjit:count=0"
      org.apache.derbyTesting.functionTests.harness.RunSuite derbylang

      With the second command I see the following in derbylang.sum
      > Exception in thread "main" java.lang.NoClassDefFoundError:
      -Xgcpolicy:optthruput-Xjit:count=0
      > Caused by: java.lang.ClassNotFoundException:
      -Xgcpolicy:optthruput-Xjit:count=0
      > Could not find the main class: -Xgcpolicy:optthruput-Xjit:count=0.
      Program will exit.
      Test Failed.

          • End: checkConstraint jdk1.6.0 derbylang:derbylang 2010-10-19
            16:58:24 ***

        Activity

        Kathey Marsden added a comment -

        Here is a fix for this issue. The harness was not careful when merging flags to prevent prepending or appending ^'s. It really should have a separate method abstracted out for merging the flags, but since the old harness is hopefully dead code, I didn't bother.

        Kathey Marsden added a comment -

        backported to 10.5


          People

          • Assignee:
            Kathey Marsden
            Reporter:
            Kathey Marsden
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development