Derby
  1. Derby
  2. DERBY-462

DatabaseMetaData method supportsConvert() returns true

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 10.1.2.1, 10.2.1.6
    • Fix Version/s: 10.7.1.1
    • Component/s: JDBC
    • Labels:
      None
    • Urgency:
      Normal
    • Issue & fix info:
      Newcomer

      Description

      but we don't support the scalar escape function CONVERT yet.
      I get the same result from both the embedded and client driver.

      See JDBC 3.0 specification, appendix C.5 for a description of CONVERT and
      http://java.sun.com/j2se/1.4.2/docs/api/java/sql/DatabaseMetaData.html#supportsConvert().

      Until we do, we sould return false from supportsConvert().

      1. d462.diff
        1 kB
        Knut Anders Hatlen
      2. foo.java
        0.8 kB
        Dag H. Wanvik

        Issue Links

          Activity

          Dag H. Wanvik added a comment -

          added simple repro.

          Mike Matrigali added a comment -

          Triaged July 10, 2009: assigned normal urgency.

          Knut Anders Hatlen added a comment -

          The attached patch makes supportsConvert() return false and updates DatabaseMetaDataTest to expect false. Running the regression test suites now.

          Knut Anders Hatlen added a comment -

          Regression tests ran cleanly.

          Dag H. Wanvik added a comment -

          Thanks for this patch, Knut. Looks like a simple and obvious fix!
          +1

          Knut Anders Hatlen added a comment -

          Thanks, Dag!
          Committed revision 955546.


            People

            • Assignee:
              Knut Anders Hatlen
              Reporter:
              Dag H. Wanvik
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development