Derby
  1. Derby
  2. DERBY-4570

test failure in ij7 with cdc foundation profile (ibm's weme6.2)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.6.1.0
    • Fix Version/s: 10.6.1.0
    • Component/s: Test
    • Labels:
      None
    • Environment:
      cdc foundation profile from ibm's weme6.2
    • Bug behavior facts:
      Regression Test Failure

      Description

      I see the following test failure, which looks like somehow we're calling java.sql.Driver when that class is not available with the foundation profile.
      This I think is related to the changes to ij:
      ------------------------------------------------------------------------
      r916014 | rhillegas | 2010-02-24 14:39:49 -0800 (Wed, 24 Feb 2010) | 1 line

      DERBY-4550: Commit Sylvain Leroux's patch which adds qualified identifiers to ij.
      ------------------------------------------------------------------------
      I've not investigated further, perhaps this is a test issue after all, but I marked it tools for now.
      This is the output from suites.All:

      1) ij7(org.apache.derbyTesting.functionTests.tests.tools.ToolScripts)junit.framework.ComparisonFailure: Output at line 250 expected:<ij(DERBY4550_1)> create table t1(a int, b int);> but was:<JAVA ERROR: java.lang.NoClassDefFoundError: java.sql.Driver>
      at junit.framework.AssertionFailedError.<init>(AssertionFailedError.java:11)
      at junit.framework.ComparisonFailure.<init>(ComparisonFailure.java:19)
      at org.apache.derbyTesting.functionTests.util.CanonTestCase.compareCanon(CanonTestCase.java:106)
      at org.apache.derbyTesting.functionTests.util.ScriptTestCase.runTest(ScriptTestCase.java:198)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:109)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)

      1. DERBY-4570.patch
        12 kB
        Sylvain Leroux

        Issue Links

          Activity

          Gavin made changes -
          Workflow jira [ 12500175 ] Default workflow, editable Closed status [ 12800402 ]
          Myrna van Lunteren made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Bug behavior facts [Regression Test Failure]
          Rick Hillegas added a comment -

          Thanks Sylvain and Knut. I have verified that ToolScript succeeds again on a small device (phoneME emulator run on Ubuntu under vmware on my mac). The fix looks good to me. Thanks.

          Knut Anders Hatlen made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Issue & fix info [Patch Available]
          Fix Version/s 10.6.0.0 [ 12313727 ]
          Resolution Fixed [ 1 ]
          Knut Anders Hatlen added a comment -

          Thanks for the patch, Sylvain. I believe that this should be enough to get the test working again on the small platforms, but I don't have an environment in which I could test that it actually works.

          Committed revision 917466.

          Let's wait and see if the nightly tests run cleanly before we close this issue.

          Sylvain Leroux made changes -
          Issue & fix info [Patch Available]
          Sylvain Leroux made changes -
          Attachment DERBY-4570.patch [ 12437391 ]
          Sylvain Leroux added a comment -

          Attaching a patch for this issue.

          I moved the DERBY-4550 related tests to their own files:
          A java/testing/org/apache/derbyTesting/functionTests/tests/tools/qualifiedIdentifiers.sql
          A java/testing/org/apache/derbyTesting/functionTests/master/qualifiedIdentifiers.out

          And I changed ToolScript.java to only run these tests if JDBC3 is available. Is it sufficient to prevent them to run on small devices?

          Sylvain Leroux made changes -
          Assignee Sylvain Leroux [ sleroux ]
          Sylvain Leroux added a comment -

          Sorry for the late answer.

          I will move the new tests introduced by DERBY-4550 on their own suite asap.

          Sylvain.

          Rick Hillegas made changes -
          Link This issue is part of DERBY-4550 [ DERBY-4550 ]
          Rick Hillegas made changes -
          Field Original Value New Value
          Component/s Test [ 11413 ]
          Component/s Tools [ 11414 ]
          Rick Hillegas added a comment -

          Changing the category of this bug to Test. The problem is that the new tests are making a new connection to the database. This causes ij to invoke DriverManager.getConnection(), which you can't do on a small device.

          Myrna van Lunteren created issue -

            People

            • Assignee:
              Sylvain Leroux
              Reporter:
              Myrna van Lunteren
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development