Derby
  1. Derby
  2. DERBY-4545

test_11_tableFunctionColumns fails with weme (J2ME) with 'java.lang.NoClassDefFoundError: java.sql.DriverManager'

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.6.1.0
    • Fix Version/s: 10.6.1.0
    • Component/s: Test
    • Labels:
      None
    • Environment:
      IBM weme6.2
      Windows XP - x86 - 5.1 build 2600 Service Pack 3
    • Bug behavior facts:
      Regression Test Failure

      Description

      Starting Friday Feb 3, testing svn 907159, IBM weme 6.2 fails as follows.
      http://people.apache.org/~myrnavl/derby_test_results/main/windows/testlog/weme6.2/907159-suites.All_diff.txt

      It would appear that either the test needs to be disabled for J2ME or DriverManager use needs to be removed from the test.

      1) test_11_tableFunctionColumns(org.apache.derbyTesting.functionTests.tests.lang.UDTTest)java.sql.SQLException: The exception 'java.lang.NoClassDefFoundError: java.sql.DriverManager' was thrown while evaluating an expression.
      at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.seeNextException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedConnection.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.ConnectionChild.handleException(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedStatement.executeStatement(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedPreparedStatement.executeStatement(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedPreparedStatement.executeQuery(Unknown Source)
      at org.apache.derbyTesting.functionTests.tests.lang.GeneratedColumnsHelper.assertResults(GeneratedColumnsHelper.java:335)
      at org.apache.derbyTesting.functionTests.tests.lang.UDTTest.test_11_tableFunctionColumns(UDTTest.java:814)
      at java.lang.reflect.AccessibleObject.invokeV(AccessibleObject.java:195)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:109)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      Caused by: java.sql.SQLException: Java exception: 'java.sql.DriverManager: java.lang.NoClassDefFoundError'.
      at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
      at org.apache.derby.impl.jdbc.Util.javaException(Unknown Source)
      at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(Unknown Source)
      ... 41 more
      Caused by: java.lang.NoClassDefFoundError: java.sql.DriverManager
      at org.apache.derbyTesting.functionTests.tests.lang.UDTTest.hashmapReader(UDTTest.java:854)
      at org.apache.derby.exe.ac8b55d5f4x0126xa337xbefex00001d5b55d51.g0(Unknown Source)
      at java.lang.reflect.AccessibleObject.invokeL(AccessibleObject.java:203)
      at org.apache.derby.impl.services.reflect.ReflectMethod.invoke(Unknown Source)
      at org.apache.derby.impl.sql.execute.VTIResultSet.openCore(Unknown Source)
      at org.apache.derby.impl.sql.execute.BasicNoPutResultSetImpl.open(Unknown Source)
      at org.apache.derby.impl.sql.GenericPreparedStatement.executeStmt(Unknown Source)
      at org.apache.derby.impl.sql.GenericPreparedStatement.execute(Unknown Source)
      ... 37 more

        Activity

        Kathey Marsden created issue -
        Rick Hillegas made changes -
        Field Original Value New Value
        Assignee Rick Hillegas [ rhillegas ]
        Rick Hillegas added a comment -

        Attaching derby-4545-01-aa-disableOnJSR169.diff. This patches UDTTest to run cleanly on small devices. The test now runs cleanly for me on phoneME. Committed at subversion revision 909123.

        Rick Hillegas made changes -
        Attachment derby-4545-01-aa-disableOnJSR169.diff [ 12435607 ]
        Rick Hillegas made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Myrna van Lunteren added a comment -
        Kathey Marsden made changes -
        Fix Version/s 10.6.1.0 [ 12313727 ]
        Kathey Marsden made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Gavin made changes -
        Workflow jira [ 12498762 ] Default workflow, editable Closed status [ 12800409 ]

          People

          • Assignee:
            Rick Hillegas
            Reporter:
            Kathey Marsden
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development