Derby
  1. Derby
  2. DERBY-4465

Typo in error message from SQLChar

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 10.5.3.0
    • Fix Version/s: 10.6.1.0
    • Component/s: SQL
    • Labels:
      None

      Description

      An error message raised by SQLChar says java.sql.String instead of java.lang.String. See for instance the message text for one of the nested exceptions in DERBY-4455:

      java.sql.SQLException: An IOException was thrown when reading a 'java.sql.String' from an InputStream.

      1. typo.diff
        0.6 kB
        Knut Anders Hatlen

        Activity

        Knut Anders Hatlen added a comment -

        The attached patch calls String.class.getName() instead of hard-coding the class name. No test is added, since this error is only raised if there's a bug in Derby, if I understand it correctly. All the regression tests ran cleanly.

        Kristian Waagan added a comment -

        +1 to commit.

        Knut Anders Hatlen added a comment -

        Thanks, Kristian. Committed revision 888754.


          People

          • Assignee:
            Knut Anders Hatlen
            Reporter:
            Knut Anders Hatlen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development