Derby
  1. Derby
  2. DERBY-4461

'testD151(...Derby151Test)java.sql.SQLException: Failed to start database' (and more ...) on Suse EE S 10 Linux/IBM 1.6.0, Fedora Core 5/Sun 1.6.0-b105, Win XP/Sun 1.6.0_10

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.6.1.0
    • Fix Version/s: 10.6.1.0
    • Component/s: Test
    • Labels:
      None
    • Environment:

      Description

      On e.g. SunOS 5.11 w/Sun 1.6.0-b105 and SunOS 5.10 w/Sun 1.6.0_15 I don't see the failure.

      See http://dbtg.foundry.sun.com/derby/test/trunk16/jvmAll/testing/Limited/testSummary-886880.html

      Could this be an "too old" os-problem?

      The failure occurs in a new test introduced in DERBY-151 / r886831.

        Issue Links

          Activity

          Dag H. Wanvik added a comment -

          Seems behavior is different across VMs here; I was half expecting issues with this test since I
          interrupt a thread...

          Dag H. Wanvik added a comment - - edited

          Uploading a patch which clears the interrupt flag from the app thread, which is the one affected in the embedded part of the test. This makes DERBY151Test run on Linux also; will test it on Windows too.

          (update): Worked on Vista/CYGWIN.

          Dag H. Wanvik added a comment -

          Committed fix as svn 887305, resolving.

          Ole Solberg added a comment -

          I see a variant of this in last nights regression tests with ":SQLSTATE: XJ001Java exception: ': java.nio.channels.ClosedByInterruptException'.".

          See e.g.
          http://dbtg.foundry.sun.com/derby/test/Daily/jvm1.7/testing/testlog/lin/888874-suitesAll_diff.txt
          http://dbtg.foundry.sun.com/derby/test/Daily/jvm1.5/testing/testlog/lin/888874-suitesAll_diff.txt
          http://dbtg.foundry.sun.com/derby/test/trunk16/jvmAll/testing/testlog/JDK16Jvm1.6Linux-2.6.17-1.2174_FC5_i686-i686/888925-org.apache.derbyTesting.functionTests.suites.All_diff.txt
          http://dbtg.foundry.sun.com/derby/test/trunk16/jvmAll/testing/testlog/JDK16Jvm1.6CYGWIN_NT-5.1_i686-unknown/888925-org.apache.derbyTesting.functionTests.suites.All_diff.txt

          The signature is

          1) testD151(org.apache.derbyTesting.functionTests.tests.store.Derby151Test)java.sql.SQLException: DERBY SQL error: SQLCODE: -1, SQLSTATE: XJ040, SQLERRMC: Failed to start database 'wombat', see the next exception for details.::SQLSTATE: XJ001Java exception: ': java.nio.channels.ClosedByInterruptException'.
          at org.apache.derby.client.am.SQLExceptionFactory40.getSQLException(Unknown Source)
          at org.apache.derby.client.am.SqlException.getSQLException(Unknown Source)
          at org.apache.derby.jdbc.ClientDriver.connect(Unknown Source)
          at java.sql.DriverManager.getConnection(DriverManager.java:620)
          at java.sql.DriverManager.getConnection(DriverManager.java:200)
          at org.apache.derbyTesting.junit.DriverManagerConnector.openConnection(DriverManagerConnector.java:76)
          at org.apache.derbyTesting.junit.DriverManagerConnector.openConnection(DriverManagerConnector.java:43)
          at org.apache.derbyTesting.junit.TestConfiguration.openDefaultConnection(TestConfiguration.java:1350)
          at org.apache.derbyTesting.junit.BaseJDBCTestCase.openDefaultConnection(BaseJDBCTestCase.java:421)
          at org.apache.derbyTesting.junit.BaseJDBCTestCase.getConnection(BaseJDBCTestCase.java:103)
          at org.apache.derbyTesting.junit.BaseJDBCTestCase.createStatement(BaseJDBCTestCase.java:135)
          at org.apache.derbyTesting.functionTests.tests.store.Derby151Test.tearDown(Derby151Test.java:101)
          at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:109)
          at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
          at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
          at junit.extensions.TestSetup.run(TestSetup.java:25)
          at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
          at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
          at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
          at junit.extensions.TestSetup.run(TestSetup.java:25)
          at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
          at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
          at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
          at junit.extensions.TestSetup.run(TestSetup.java:25)
          Caused by: org.apache.derby.client.am.SqlException: DERBY SQL error: SQLCODE: -1, SQLSTATE: XJ040, SQLERRMC: Failed to start database 'wombat', see the next exception for details.::SQLSTATE: XJ001Java exception: ': java.nio.channels.ClosedByInterruptException'.
          at org.apache.derby.client.am.Connection.completeSqlca(Unknown Source)
          at org.apache.derby.client.net.NetConnectionReply.parseRdbAccessFailed(Unknown Source)
          at org.apache.derby.client.net.NetConnectionReply.parseAccessRdbError(Unknown Source)
          at org.apache.derby.client.net.NetConnectionReply.parseACCRDBreply(Unknown Source)
          at org.apache.derby.client.net.NetConnectionReply.readAccessDatabase(Unknown Source)
          at org.apache.derby.client.net.NetConnection.readSecurityCheckAndAccessRdb(Unknown Source)
          at org.apache.derby.client.net.NetConnection.flowSecurityCheckAndAccessRdb(Unknown Source)
          at org.apache.derby.client.net.NetConnection.flowUSRIDPWDconnect(Unknown Source)
          at org.apache.derby.client.net.NetConnection.flowConnect(Unknown Source)
          at org.apache.derby.client.net.NetConnection.<init>(Unknown Source)
          at org.apache.derby.client.net.NetConnection40.<init>(Unknown Source)
          at org.apache.derby.client.net.ClientJDBCObjectFactoryImpl40.newNetConnection(Unknown Source)
          ... 43 more

          Dag H. Wanvik added a comment -

          I think this has been solved by the fix for Derby-4463, Ole, which went in as 888881, so
          let's see tomorrow.


            People

            • Assignee:
              Dag H. Wanvik
              Reporter:
              Ole Solberg
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development