Derby
  1. Derby
  2. DERBY-4438

'Table/View 'T1' already exists in Schema 'APP'' in lang.DropTableTest on phoneME/cvm

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 10.6.1.0
    • Fix Version/s: 10.6.1.0
    • Component/s: Test
    • Labels:
      None
    • Environment:
    • Bug behavior facts:
      Regression Test Failure

      Description

      See http://dbtg.foundry.sun.com/derby/test/Daily/javaME/testing/Limited/testSummary-833084.html
      http://dbtg.foundry.sun.com/derby/test/Daily/javaME/FailReports/833084_bySig.html same signature as DERBY-4392 :
      org.apache.derbyTesting.functionTests.tests.lang.DropTableTest [org.apache.derbyTesting.functionTests.tests.lang.CheckConstraintTest]:
      DERBY-4392 Closed - signature[1]

      Caused by test not cleaning up and phoneME/cvm executing tests in a different order than other jvms

      Introduced by r833055 / DERBY-4423.

      I am testing a fix.

      1. DERBY-4438_stat.txt
        0.1 kB
        Ole Solberg
      2. DERBY-4438_diff.txt
        1 kB
        Ole Solberg

        Activity

        Ole Solberg added a comment -

        suites.All ran ok on Sun jvm1.6
        lang._Suites ran ok on phoneME/cvm

        Ole Solberg added a comment -

        DERBY-4438_diff was committed to trunk as revision 833414.


          People

          • Assignee:
            Ole Solberg
            Reporter:
            Ole Solberg
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development