Derby
  1. Derby
  2. DERBY-4427

TestConfiguration.existingServerSuite(....,portNumber) must use the supplied portNumber

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 10.6.1.0
    • Fix Version/s: 10.6.1.0
    • Component/s: Test
    • Labels:
      None
    • Environment:
      All

      Description

      When testing distributed replication I found that test clients/load would always use (default) port 1527 even if a different master port number had been specified. The correct/specified port number was used when starting the master server.
      This was caused by a call to 'TestConfiguration.getCurrent().getPort()' on an uninitialized TestConfiguration. The fix is to use the supplied portNumber parameter.

      1. DERBY-existingServer_Fix_stat.txt
        0.1 kB
        Ole Solberg
      2. DERBY-existingServer_Fix_diff.txt
        0.9 kB
        Ole Solberg

        Activity

        Ole Solberg added a comment -

        The problem was not in 10.5.
        10.5 had the original correct use of the supplied portNumber parameter.

        Ole Solberg added a comment -

        Committed DERBY-existingServer_Fix_stat.txt to trunk as revision 830897.

        Ole Solberg added a comment -

        Yes, for completeness, it should be backported.

        Myrna van Lunteren added a comment -

        I assume this is a problem with 10.5 also; if/when committed, can it get backported?

        Knut Anders Hatlen added a comment -

        Hi Ole,
        The fix looks good. +1

        Ole Solberg added a comment -

        suites.All ran ok,
        as well as distributed replication tests with master port different from 1527.


          People

          • Assignee:
            Ole Solberg
            Reporter:
            Ole Solberg
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development