Derby
  1. Derby
  2. DERBY-4384

testDynamicArgsMetaData has been failing since Aug 24th on weme6.2 with NoSuchMethodError

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.6.1.0
    • Fix Version/s: 10.6.1.0
    • Component/s: Test
    • Labels:
      None
    • Environment:
      weme 6.2
    • Bug behavior facts:
      Regression Test Failure

      Description

      testDynamicArgsMetaData has been failing on weme6.2 with following exception.

      1) testDynamicArgsMetaData(org.apache.derbyTesting.functionTests.tests.lang.OffsetFetchNextTest)java.lang.NoSuchMethodError: java/sql/PreparedStatement.getParameterMetaData()Ljava/sql/ParameterMetaData;
      at org.apache.derbyTesting.functionTests.tests.lang.OffsetFetchNextTest.testDynamicArgsMetaData(OffsetFetchNextTest.java:788)
      at java.lang.reflect.AccessibleObject.invokeV(AccessibleObject.java:195)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:109)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)

      Kathey posted in her mail to Derby dev list that "I assume the failure was introduced by revision 807337 for DERBY-4208 (Parameters ? with OFFSET and/or FETCH) by Dag. That is the change that added the test on August 24."

        Activity

        Mamta A. Satoor added a comment -

        Disabled the test fixture from running in JSR169 with revision 818730. Commit comments are as follows

        Disabling the test fixture testDynamicArgsMetaData from running in JSR169 environment because it makes a call PreparedStatement.getParameterMetaData() which is unavailable in JSR169.

        Dag H. Wanvik added a comment -

        Thanks for fixing this in my absence, Mamta. I was under the impression we ran our nightlies with JSR169 now, but it seems I am wrong. I'll check with Ole.


          People

          • Assignee:
            Unassigned
            Reporter:
            Mamta A. Satoor
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development