Derby
  1. Derby
  2. DERBY-4307

testRunTests in RuntimeinfoTest fails periodically with Assertion failure checking output

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 10.6.1.0
    • Fix Version/s: 10.5.3.2, 10.6.1.0
    • Component/s: Test
    • Labels:
      None
    • Bug behavior facts:
      Regression Test Failure

      Description

      The nightly runs have reported intermittent occurences of the failure below on multiple platforms. It might be helpful to have the assertion print the expected and actual output so we can compare and see why it doesn't match:

      1) testRunTests(org.apache.derbyTesting.functionTests.tests.derbynet.RuntimeInfoTest)junit.framework.AssertionFailedError
      at org.apache.derbyTesting.functionTests.tests.derbynet.RuntimeInfoTest.x_testRuntimeInfoLocale(RuntimeInfoTest.java:158)
      at org.apache.derbyTesting.functionTests.tests.derbynet.RuntimeInfoTest.testRunTests(RuntimeInfoTest.java:92)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:109)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        9h 18m 1 Kristian Waagan 15/Jul/09 15:18
        Resolved Resolved Closed Closed
        546d 8h 5m 1 Kathey Marsden 12/Jan/11 22:24
        Closed Closed Reopened Reopened
        15d 2h 18m 1 Myrna van Lunteren 28/Jan/11 00:42
        Reopened Reopened Closed Closed
        8m 1s 1 Myrna van Lunteren 28/Jan/11 00:50
        Gavin made changes -
        Workflow jira [ 12470597 ] Default workflow, editable Closed status [ 12800295 ]
        Myrna van Lunteren made changes -
        Resolution Fixed [ 1 ]
        Status Reopened [ 4 ] Closed [ 6 ]
        Fix Version/s 10.5.3.2 [ 12315436 ]
        Myrna van Lunteren added a comment - - edited

        backported to 10.5 together with the changes for DERBY-3843, with revision 1064388.

        Myrna van Lunteren made changes -
        Resolution Fixed [ 1 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Myrna van Lunteren added a comment -

        reopen to record backport to 10.5.

        Kathey Marsden made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Kristian Waagan made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Issue & fix info [Patch Available]
        Fix Version/s 10.6.0.0 [ 12313727 ]
        Resolution Fixed [ 1 ]
        Kristian Waagan added a comment -

        Thanks for the information, Tiago.

        I committed patch 1a to trunk with revision 794276.

        Tiago R. Espinha added a comment -

        I had actually ran into this when I was creating the test. I had to add dashes to the German locale because it wasn't matching.

        I haven't tested the patch myself but it looks good

        Kristian Waagan made changes -
        Issue & fix info [Patch Available]
        Kristian Waagan made changes -
        Attachment derby-4307-1a-test_fix.diff [ 12413539 ]
        Kristian Waagan added a comment -

        Attaching a possible fix for the issue as patch 1a.

        The reason why the test started failing, was the commit of the new localized messages (revision 793870).
        The relevant message is this one (in German):
        DRDA_RuntimeInfoPreparedStatementHeader.I=Informationen zur vorbereiteten Anweisung\: \n\tAnwsg-ID\t\tSQL-Text\n\t------------\t----------\n

        As far as I can see, the original English message is old and has been kept unchanged for a long time, but the localized messages were all changed to correct a mismatch for the number of dashes used.
        In the English message, there are 13 and 11 dashes. In the "old" localized ones, there were 14 and 12. This was corrected to 13 and 11 in the newest version of the messages.

        Since the original English message hasn't been changed for such a long time, I chose to fix the match string in the test rather then fixing all the localized messages.

        Patch ready for review.

        Kristian Waagan made changes -
        Field Original Value New Value
        Assignee Kristian Waagan [ kristwaa ]
        Kathey Marsden created issue -

          People

          • Assignee:
            Kristian Waagan
            Reporter:
            Kathey Marsden
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development