Derby
  1. Derby
  2. DERBY-4132

intermittent test failure: extra lock in store/updatelocksJDBC30

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Test
    • Labels:
      None
    • Bug behavior facts:
      Regression Test Failure

      Description

      Test failure with 10.5 revision 757599 - passed on rerun:

                      • Diff file derbyall/encryptionAll/storemats/storemats/updatelocksJDBC30
                        .diff
          • Start: updatelocksJDBC30 jdk1.5.0 storemats:storemats 2009-03-23 23:03:36 **
            *
            15594d15593
            < APP |UserTran|ROW |1 |U |A |(2,6) |GRANT|ACTIVE
            15595a15595
            > APP |UserTran|ROW |2 |U |A |(2,6) |GRANT|ACTIVE
            15602d15601
            < APP |UserTran|ROW |1 |U |A |(2,6) |GRANT|ACTIVE
            15603a15603
            > APP |UserTran|ROW |2 |U |A |(2,6) |GRANT|ACTIVE
            Test Failed.
          • End: updatelocksJDBC30 jdk1.5.0 storemats:storemats 2009-03-23 23:04:05 **

      This was the run as part of encryptionAll - it passed as part of normal storemats.
      This was with ibm 1.5:
      Java(TM) 2 Runtime Environment, Standard Edition (build pxi32devifx-20070806 (SR
      5a))
      IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 Linux x86-32 j9vmxi3223-20070426 (JI
      T enabled)
      J9VM - 20070420_12448_lHdSMR
      JIT - 20070419_1806_r8
      GC - 200704_19)
      JCL - 20070725

      There were no check-ins that could've cause this to pop up, and it's the only time I've seen this...

        Issue Links

          Activity

          Gavin made changes -
          Workflow jira [ 12459486 ] Default workflow, editable Closed status [ 12800019 ]
          Myrna van Lunteren made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Mike Matrigali made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Assignee Mike Matrigali [ mikem ]
          Resolution Duplicate [ 3 ]
          Mike Matrigali added a comment -

          resolving as duplicate of DERBY-4211.

          Dag H. Wanvik made changes -
          Component/s Test [ 11413 ]
          Dag H. Wanvik made changes -
          Component/s Regression Test Failure [ 12310664 ]
          Myrna van Lunteren made changes -
          Affects Version/s 10.5.1.0 [ 12313770 ]
          Knut Anders Hatlen made changes -
          Field Original Value New Value
          Link This issue is duplicated by DERBY-4211 [ DERBY-4211 ]
          Knut Anders Hatlen added a comment -
          Myrna van Lunteren created issue -

            People

            • Assignee:
              Mike Matrigali
              Reporter:
              Myrna van Lunteren
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development