Derby
  1. Derby
  2. DERBY-4052

SQLChar.copyState() doesn't copy localeFinder

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 10.5.1.1
    • Fix Version/s: 10.5.3.2, 10.6.2.2, 10.7.1.1
    • Component/s: SQL
    • Labels:
      None
    • Urgency:
      Low
    • Issue & fix info:
      Known fix, Newcomer

      Description

      The last line of SQLChar.copyState() looks incorrect.

      this.localeFinder = localeFinder;

      This line doesn't do anything, since the left side and the right side of the assignment are identical.

      It might be intentional, but in that case there should be a comment explaining why. Looking at the rest of the method, it looks like the intention is that the right side of the assignment should be other.localeFinder.

      1. derby-4052.patch
        0.5 kB
        Yun Lee
      2. derby-4052.stat
        0.1 kB
        Yun Lee

        Issue Links

          Activity

          Mike Matrigali added a comment -

          backported to 10.5 and 10.6. resoloving and setting owner back to original.

          Mike Matrigali added a comment -

          backporting to 10.6 and 10.5, temp assigning to myself while backporting.

          Kathey Marsden added a comment -

          Reopen for backport.

          Yun Lee added a comment -

          Thanks for your check, Knut.

          I have examined the use of the localFinder, but haven't run test strcitly, I will improve it later. Thanks for your remind!

          Knut Anders Hatlen added a comment -

          All the regression tests ran cleanly in my environment.
          Committed revision 961892.

          Knut Anders Hatlen added a comment -

          Hi Yun. The patch looks fine to me. Did you run the regression tests to see if it caused any problems?

          Yun Lee added a comment -

          Hi, Knut. I agree with copying from the other.localeFinder and attach a patch. Please check it, thanks!

          Knut Anders Hatlen added a comment - - edited

          Triaged for 10.5.2. Looks like the fix is known: use other.localeFinder on the right side.

          Kristian Waagan added a comment -

            People

            • Assignee:
              Yun Lee
              Reporter:
              Knut Anders Hatlen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development