Uploaded image for project: 'Derby'
  1. Derby
  2. DERBY-4047

tests updatelocks and updatelocksJDBC30.sql are not run anywhere; should get evaluated

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 10.6.1.0
    • Component/s: Test
    • Labels:
      None

      Description

      I noticed the tests store/updatelocks.sql and store/updatelocksJDBC30.sql are not in use.
      They should get evaluated for inclusion in the tests - they should either get included - and preferably converted to junit - or get deleted.

      1. DERBY-4047_a.diff
        89 kB
        Myrna van Lunteren

        Issue Links

          Activity

          myrna Myrna van Lunteren added a comment -

          I started with just running the tests and updatelocksJDBC30.out only diffed from the master in that is now license header information in the output, so I updated the master with revision 741687.
          However, updatelocks shows a number of different locking rows. I don't know whether there is a bug hiding here or no, and would appreciate someone who might know to take a look.
          Attaching a patch that shows the new output.

          mikem Mike Matrigali added a comment -

          checked in new master and added to the store nightly suite. Am resolving it, if someone wants to convert this test open another issue. Converting the test would not be too hard, just need to be able to queries on the lock
          table. It actually will be much cleaner as a converted test as it uses "sub" scripts which really want to be program calls to a single routine after varying the setup. The problem is that calling the single routine
          returns different expected results based on the setup.

          dagw Dag H. Wanvik added a comment -

          Just FYI, I am almost done converting updatelocks.sql to JUnit. I'll probably create a new JIRA for it.

          houxzhang Houx Zhang added a comment -

          Oh, Dag it's fortunate to see your message, . I just planned to begin to work on this converting. Nice to get your message before my starting.

          dagw Dag H. Wanvik added a comment -

          Good! Please feel free to pick up conversion of updatelocksJDBC30.sql, though. I am not planning to do that soon.

          dagw Dag H. Wanvik added a comment -

          Cf. DERBY-5305 for the conversion of updatelocks.sql.

          houxzhang Houx Zhang added a comment -

          Thanks for your encourage, I will consider picking it up after finishing my other issues, maybe several weeks later.


            People

            • Assignee:
              mikem Mike Matrigali
              Reporter:
              myrna Myrna van Lunteren
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development