Derby
  1. Derby
  2. DERBY-3957

Generated columns are not recalculated when you update a column through an updatable ResultSet.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 10.5.1.1
    • Fix Version/s: None
    • Component/s: SQL
    • Labels:
      None

      Description

      ResultSet.updateXXX() does not update a generated column when you update one of the columns it depends on.

        Issue Links

          Activity

          Rick Hillegas added a comment -

          Operator error. I was not calling ResultSet.updateRow() and ResultSet.insertRow() before committing. Will write some more tests to verify that the behavior is correct.

          Kristian Waagan added a comment -

          Not really important at all, except for the quality of the Jira issue reports, but shouldn't this issue be resolved as "Invalid" due to the operator error?

          Fixed - A fix for this issue is checked into the tree and tested.
          Invalid - The problem isn't valid and it can't be fixed.


            People

            • Assignee:
              Rick Hillegas
              Reporter:
              Rick Hillegas
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development