Derby
  1. Derby
  2. DERBY-3916

StressMultiTest fails with protocol error due to java.util.NoSuchElementException in org.apache.derby.impl.store.raw.xact.TransactionTable.getTransactionInfo

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 10.5.1.1
    • Fix Version/s: None
    • Component/s: Store
    • Labels:
      None
    • Environment:
      Linux IBM 1.5
    • Urgency:
      Normal
    • Bug behavior facts:
      Regression Test Failure

      Description

      I saw this 10.5.0.0 alpha - (705444) with IBM JDK 1.5 on Linux.

      The failure on the client was:
      1) testStressMulti(org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest)junit.framework.AssertionFailedError: Caused by:
      java.sql.SQLException: Network protocol exception: DSS length not 0 at end of same id chain parse. The connection has been terminated.
      at org.apache.derby.client.am.SQLExceptionFactory.getSQLException(Unknown Source)
      at org.apache.derby.client.am.SqlException.getSQLException(Unknown Source)
      at org.apache.derby.client.am.Statement.executeQuery(Unknown Source)
      at org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest$StressMultiRunnable.select(StressMultiTest.java:535)
      at org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest$StressMultiRunnable.run(StressMultiTest.java:409)
      at java.lang.Thread.run(Thread.java:801)
      Caused by: org.apache.derby.client.am.DisconnectException: Network protocol exception: DSS length not 0 at end of same id chain parse. The connection has been terminated.
      at org.apache.derby.client.net.Reply.endOfSameIdChainData(Unknown Source)
      at org.apache.derby.client.net.NetStatementReply.readOpenQuery(Unknown Source)
      at org.apache.derby.client.net.StatementReply.readOpenQuery(Unknown Source)
      at org.apache.derby.client.net.NetStatement.readOpenQuery_(Unknown Source)
      at org.apache.derby.client.am.Statement.readOpenQuery(Unknown Source)
      at org.apache.derby.client.am.Statement.flowExecute(Unknown Source)
      at org.apache.derby.client.am.Statement.executeQueryX(Unknown Source)
      ... 4 more

      at org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest.handleException(StressMultiTest.java:331)
      at org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest.access$200(StressMultiTest.java:70)
      at org.apache.derbyTesting.functionTests.tests.multi.StressMultiTest$StressMultiRunnable.run(StressMultiTest.java:425)
      at java.lang.Thread.run(Thread.java:801)

      In the derby.log I see:
      2008-10-17 10:01:25.625 GMT Thread[DRDAConnThread_1112,5,derby.daemons] (XID = 8538484), (SESSIONID = 13), (DATABASE = wombat), (DRDAID = NF000001.AE6C-665687095683461228

      {6}

      ), Failed Statement is: select * from main2
      java.util.NoSuchElementException
      at java.util.Hashtable$HashEnumerator.nextElement(Hashtable.java:205)
      at org.apache.derby.impl.store.raw.xact.TransactionTable.getTransactionInfo(Unknown Source)
      at org.apache.derby.impl.store.raw.xact.XactFactory.getTransactionInfo(Unknown Source)
      at org.apache.derby.impl.store.raw.RawStore.getTransactionInfo(Unknown Source)
      at org.apache.derby.impl.store.access.RAMAccessManager.getTransactionInfo(Unknown Source)
      at org.apache.derby.impl.services.locks.Deadlock.buildException(Unknown Source)
      at org.apache.derby.impl.services.locks.ConcurrentLockSet.lockObject(Unknown Source)
      at org.apache.derby.impl.services.locks.ConcurrentLockSet.zeroDurationLockObject(Unknown Source)
      at org.apache.derby.impl.services.locks.AbstractPool.zeroDurationlockObject(Unknown Source)
      at org.apache.derby.impl.store.raw.xact.RowLocking2nohold.lockRecordForRead(Unknown Source)
      at org.apache.derby.impl.store.access.conglomerate.OpenConglomerate.lockPositionForRead(Unknown Source)
      at org.apache.derby.impl.store.access.conglomerate.GenericScanController.fetchRows(Unknown Source)
      at org.apache.derby.impl.store.access.heap.HeapScan.fetchNextGroup(Unknown Source)
      at org.apache.derby.impl.sql.execute.BulkTableScanResultSet.reloadArray(Unknown Source)
      at org.apache.derby.impl.sql.execute.BulkTableScanResultSet.getNextRowCore(Unknown Source)
      at org.apache.derby.impl.sql.execute.BasicNoPutResultSetImpl.getNextRow(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedResultSet.movePosition(Unknown Source)
      at org.apache.derby.impl.jdbc.EmbedResultSet.next(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.writeFDODTA(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.writeQRYDTA(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.processCommands(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.run(Unknown Source)
      Cleanup action completed
      2008-10-17 10:01:25.634 GMT : null
      java.lang.NullPointerException
      at org.apache.derby.impl.drda.DRDAConnThread.writePBSD(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.processCommands(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.run(Unknown Source)
      2008-10-17 10:01:25.634 GMT : Execution failed because of Permanent Agent Error: SVRCOD = 40; RDBNAM = wombat; diagnostic msg = null
      org.apache.derby.impl.drda.DRDAProtocolException: Execution failed because of Permanent Agent Error: SVRCOD = 40; RDBNAM = wombat; diagnostic msg = null
      at org.apache.derby.impl.drda.DRDAProtocolException.newAgentError(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.sendUnexpectedException(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.handleException(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.run(Unknown Source)
      2008-10-17 10:01:25.635 GMT : null
      java.lang.NullPointerException
      at org.apache.derby.impl.drda.DRDAConnThread.writePBSD(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.processCommands(Unknown Source)
      at org.apache.derby.impl.drda.DRDAConnThread.run(Unknown Source)

      1. derbylog.zip
        2 kB
        Kathey Marsden

        Issue Links

          Activity

          Kathey Marsden added a comment -

          I wonder if this is the insane manifestation of DERBY-3757.

          Kathey Marsden added a comment -

          attaching the derby.log

          Kristian Waagan added a comment -

          Triaged July 3, 2009: Assigned normal urgency.

          Knut Anders Hatlen added a comment -

          I agree that this is probably a variant of DERBY-3757, see my comment on that issue. I'm resolving it as a duplicate for now. If it still happens after DERBY-3757 has been fixed, we can reopen.


            People

            • Assignee:
              Unassigned
              Reporter:
              Kathey Marsden
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development