Derby
  1. Derby
  2. DERBY-3545

NullPointerException in TableFunctionTest.noSpecialCollation and specialCollation

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.4.1.3, 10.5.1.1
    • Fix Version/s: 10.4.1.3
    • Component/s: Test
    • Labels:
      None
    • Environment:
      IBM 1.5 - linux - insane jars
    • Bug behavior facts:
      Regression Test Failure

      Description

      Running the tests through ant.

        Issue Links

          Activity

          Daniel John Debrunner added a comment -

          Output from running TableFunctionTest using junit-single in a clean 10.4 branch.

          Daniel John Debrunner added a comment -

          See this on trunk as well.

          Rick Hillegas added a comment -

          What was the shell command you issued which generated this output?

          Rick Hillegas added a comment -

          I have not been able to reproduce this problem yet. This is my environment:

          Java 5
          Mac OS X
          both sane and insane Derby jars

          This is the ant command I run:

          ant -Dderby.junit.testclass=org.apache.derbyTesting.functionTests.tests.lang.TableFunctionTest junit-single

          Daniel John Debrunner added a comment -

          ant junit-clean junit-all-codeline-jars

          Rick Hillegas added a comment -

          I'm afraid I still cannot reproduce this problem. Using Java 5 on Mac OS X with both sane and insane jar files, I do not see this problem when I run the following ant command

          ant junit-clean junit-all-codeline-jars

          I do, however, see the following problem in the jdbcapi suite using both sane and insane jars:

          <testcase classname="org.apache.derbyTesting.functionTests.tests.jdbcapi.SetTransactionIsolationTest$1" name="unknown" time="0.0">
          <error message="Limitation: Record cannot be updated or inserted due to lack of space on the page. Use the parameters derby.storage.pageSize and/or derby.storage.pageReservedSpace to work around this limitation." type="org.apache.derby.impl.jdbc.EmbedSQLException">java.sql.SQLException: Limitation: Record cannot be updated or inserted due to lack of space on the page. Use the parameters derby.storage.pageSize and/or derby.storage.pageReservedSpace to work around this limitation.
          at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(SQLExceptionFactory.java:45)
          at org.apache.derby.impl.jdbc.Util.generateCsSQLException(Util.java:201)
          at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException(TransactionResourceImpl.java:391)
          at org.apache.derby.impl.jdbc.TransactionResourceImpl.handleException(TransactionResourceImpl.java:346)
          at org.apache.derby.impl.jdbc.EmbedConnection.handleException(EmbedConnection.java:2082)
          at org.apache.derby.impl.jdbc.ConnectionChild.handleException(ConnectionChild.java:81)
          at org.apache.derby.impl.jdbc.EmbedStatement.executeStatement(EmbedStatement.java:1325)
          at org.apache.derby.impl.jdbc.EmbedPreparedStatement.executeStatement(EmbedPreparedStatement.java:1652)
          at org.apache.derby.impl.jdbc.EmbedCallableStatement.executeStatement(EmbedCallableStatement.java:117)
          at org.apache.derby.impl.jdbc.EmbedPreparedStatement.execute(EmbedPreparedStatement.java:1307)
          at org.apache.derbyTesting.junit.CleanDatabaseTestSetup.compressObjects(CleanDatabaseTestSetup.java:267)
          at org.apache.derbyTesting.junit.CleanDatabaseTestSetup.cleanDatabase(CleanDatabaseTestSetup.java:166)
          at org.apache.derbyTesting.junit.CleanDatabaseTestSetup.setUp(CleanDatabaseTestSetup.java:109)
          at junit.extensions.TestSetup$1.protect(TestSetup.java:20)
          at junit.extensions.TestSetup.run(TestSetup.java:25)
          at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
          Caused by: ERROR XSDA3: Limitation: Record cannot be updated or inserted due to lack of space on the page. Use the parameters derby.storage.pageSize and/or derby.storage.pageReservedSpace to work around this limitation.
          at org.apache.derby.iapi.error.StandardException.newException(StandardException.java:276)
          at org.apache.derby.impl.store.raw.data.CopyRowsOperation.writeOptionalDataToBuffer(CopyRowsOperation.java:287)
          at org.apache.derby.impl.store.raw.data.CopyRowsOperation.<init>(CopyRowsOperation.java:98)
          at org.apache.derby.impl.store.raw.data.LoggableActions.actionCopyRows(LoggableActions.java:159)
          at org.apache.derby.impl.store.raw.data.BasePage.copyInto(BasePage.java:2045)
          at org.apache.derby.impl.store.raw.data.BasePage.copyAndPurge(BasePage.java:1300)
          at org.apache.derby.impl.store.raw.data.StoredPage.moveRecordForCompressAtSlot(StoredPage.java:6920)
          at org.apache.derby.impl.store.access.heap.HeapCompressScan.fetchRowsForCompress(HeapCompressScan.java:230)
          at org.apache.derby.impl.store.access.heap.HeapCompressScan.fetchNextGroup(HeapCompressScan.java:85)
          at org.apache.derby.iapi.db.OnlineCompress.defragmentRows(OnlineCompress.java:375)
          at org.apache.derby.iapi.db.OnlineCompress.compressTable(OnlineCompress.java:219)
          at org.apache.derby.catalog.SystemProcedures.SYSCS_INPLACE_COMPRESS_TABLE(SystemProcedures.java:942)
          at org.apache.derby.exe.ac8c8908bex0118xc7c0x9cecxffff8cd227a82.g0(Unknown Source)
          at org.apache.derby.impl.services.reflect.ReflectMethod.invoke(ReflectMethod.java:46)
          at org.apache.derby.impl.sql.execute.CallStatementResultSet.open(CallStatementResultSet.java:90)
          at org.apache.derby.impl.sql.GenericPreparedStatement.execute(GenericPreparedStatement.java:372)
          at org.apache.derby.impl.jdbc.EmbedStatement.executeStatement(EmbedStatement.java:1235)
          </error>
          </testcase>

          Kathey Marsden added a comment -

          I see this problem as well on linux with both IBM 1.5 and IBM 1.6 jvms.

          Rick Hillegas added a comment -

          Marking this as a duplicate of DERBY-3616. I see other, JMX-related errors when I try to run Derby JUnit tests on IBM's Java 6 on Ubuntu 7. However, I can run Derby JUnit tests on IBM's Java 5 on Ubuntu 7. In this configuration, I am able to reproduce the error described by this bug report when I use the Derby 10.4.1.2 release candidate. The problem goes away and I get a clean test-run when I run against a version of Derby built with the fix to DERBY-3616.


            People

            • Assignee:
              Unassigned
              Reporter:
              Daniel John Debrunner
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development