Derby
  1. Derby
  2. DERBY-3436

Embedded closes all open ResultSets on failure in auto-commit mode, whereas client keeps them open

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 10.4.1.3
    • Fix Version/s: None
    • Component/s: JDBC
    • Labels:
      None
    • Urgency:
      Normal
    • Bug behavior facts:
      Embedded/Client difference

      Description

      When an error happens in auto-commit mode, the embedded driver will close all open ResultSets (including holdable ones) in that transaction. The client driver will keep the ResultSets open. The embedded driver and the client driver should have the same behaviour.

      The test case testAutoCommitFailure() in jdbc4/TestDbMetaData contains code that shows the difference between client and embedded.

      DatabaseMetaData.autoCommitFailureClosesAllResultSets() currently returns true on the embedded driver (after DERBY-3422) and false on the client driver to account for this difference.

        Issue Links

          Activity

          Knut Anders Hatlen created issue -
          Knut Anders Hatlen made changes -
          Field Original Value New Value
          Link This issue is part of DERBY-310 [ DERBY-310 ]
          Kathey Marsden made changes -
          Derby Categories [Embedded/Client difference]
          Tiago R. Espinha added a comment -

          Triaged for 10.5.2.

          Assigned normal urgency.

          Tiago R. Espinha made changes -
          Urgency Normal
          Knut Anders Hatlen made changes -
          Link This issue duplicates DERBY-160 [ DERBY-160 ]
          Knut Anders Hatlen added a comment -

          Closing as duplicate of DERBY-160.

          Knut Anders Hatlen made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Duplicate [ 3 ]
          Gavin made changes -
          Workflow jira [ 12423988 ] Default workflow, editable Closed status [ 12797981 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          910d 3h 38m 1 Knut Anders Hatlen 18/Aug/10 14:30

            People

            • Assignee:
              Unassigned
              Reporter:
              Knut Anders Hatlen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development